www-client/chromium: dev channel bump to 83.0.4093.3
authorStephan Hartmann <stha09@googlemail.com>
Mon, 30 Mar 2020 11:15:02 +0000 (13:15 +0200)
committerMike Gilbert <floppym@gentoo.org>
Mon, 30 Mar 2020 18:55:35 +0000 (14:55 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/15178

www-client/chromium/Manifest
www-client/chromium/chromium-83.0.4093.3.ebuild [moved from www-client/chromium/chromium-82.0.4085.12.ebuild with 99% similarity]
www-client/chromium/files/chromium-82-clang-std.patch
www-client/chromium/files/chromium-83-clang-std.patch [new file with mode: 0644]
www-client/chromium/files/chromium-83-gcc-range.patch [new file with mode: 0644]
www-client/chromium/files/chromium-83-gcc-template.patch [new file with mode: 0644]

index fe862f25088a42863b9ba7ac0ee86baac57b6a7c..2a78bf288654b0ec26d48ce2d482b63a2252f504 100644 (file)
@@ -1,3 +1,3 @@
 DIST chromium-80.0.3987.149.tar.xz 797049332 BLAKE2B 679efd45a48fb064e2fda9b751b112ef26f9c3419ab46d28e1490729a80b18908078bd260060656199700c391f0664e7a4d1e919ee8eb71d9c8c12b6535269f2 SHA512 5abbf8ff754937a3af566474457b5cd9bbcac0e8b1a52fd95180fcf69b12515278423887668512b3136de72ebe15048c4bd79572511f68189d1e86ace4ca30cb
 DIST chromium-81.0.4044.83.tar.xz 785906212 BLAKE2B b17bb2dabd52dc8ae5a9c99b6320ea48f278273e790c2869e2d93382bae3a8101d1bcad917b0997631831b95ce33398e0501de046edd23110107d010db70f140 SHA512 aeb8a4aeb2371a9ae2fbd0be1553569338c8e699abb3bb7d614c33254a7c6adfecb7b1becfa3f3595a2f4e04eed3c429137ad7a3816ccabf7b23388f206d1ccb
-DIST chromium-82.0.4085.12.tar.xz 795107540 BLAKE2B 419f6e927b340679cec069c7f274d86c2d66f26f32e3d9c95501b9433888dd16dbae4104afde1f3d285730a263a5837a7ef4e9a5e30fb4876dae56db5a1d955d SHA512 d371b6a941af877d2444591f3af9f6458e6beaee99af686a92c282b6ebcd3c560113941dedf215106af57eea201890fa95dee776d5a188ee2ac5686629336410
+DIST chromium-83.0.4093.3.tar.xz 793608324 BLAKE2B 014eff6deacfb308eecc76a2d9a13ddf13b2eefffe044df25e2c20c3695f2c908604751ed7e794e053280fc32449381e8dfd73300201e67a9d84854f9fd851e5 SHA512 d37ae4912d3a39e4b06c91601d941ffb8a77a4b7380a603455c2839f6b8940acb8803aa32e8ae14c5033c141681ee41716a54ac2f8632240e54367a3819e091a
similarity index 99%
rename from www-client/chromium/chromium-82.0.4085.12.ebuild
rename to www-client/chromium/chromium-83.0.4093.3.ebuild
index 2ce3e53c2088f8a02ddd848b27d2b2bfd1699c03..adec560dac1e56478d8e8a56f5473f28054919ad 100644 (file)
@@ -149,6 +149,9 @@ PATCHES=(
        "${FILESDIR}/chromium-82-gcc-template.patch"
        "${FILESDIR}/chromium-82-gcc-iterator.patch"
        "${FILESDIR}/chromium-82-clang-std.patch"
+       "${FILESDIR}/chromium-83-gcc-template.patch"
+       "${FILESDIR}/chromium-83-gcc-range.patch"
+       "${FILESDIR}/chromium-83-clang-std.patch"
 )
 
 pre_build_checks() {
@@ -343,6 +346,7 @@ src_prepare() {
                third_party/qcms
                third_party/rnnoise
                third_party/s2cellid
+               third_party/schema_org
                third_party/simplejson
                third_party/skia
                third_party/skia/include/third_party/skcms
index 1ad62fbf45d1c8c75d602a9eadc4665bd9c606eb..b965496a29a8183ff0ab7b8fe960853feec59ff7 100644 (file)
@@ -1,8 +1,23 @@
+From 25f79b67da9ca6da2089ba14ccc14333e4a108b6 Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Mon, 30 Mar 2020 08:39:19 +0000
+Subject: [PATCH] libstdc++: fix namespace of nullptr_t in v8_set_return_value.h
+
+nullptr_t is defined in namespace std.
+
+Bug: 819294
+Change-Id: Ia3e8257ece1331319272ead84472eefcc7259268
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2126289
+Reviewed-by: Yuki Shiino <yukishiino@chromium.org>
+Commit-Queue: Yuki Shiino <yukishiino@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#754423}
+---
+
 diff --git a/third_party/blink/renderer/platform/bindings/v8_set_return_value.h b/third_party/blink/renderer/platform/bindings/v8_set_return_value.h
-index 07cae22..7871f55 100644
+index ed639ef..6c7ffa1 100644
 --- a/third_party/blink/renderer/platform/bindings/v8_set_return_value.h
 +++ b/third_party/blink/renderer/platform/bindings/v8_set_return_value.h
-@@ -51,7 +51,7 @@ void V8SetReturnValue(const CallbackInfo& info, const v8::Local<S> value) {
+@@ -116,7 +116,7 @@
  
  // nullptr
  template <typename CallbackInfo>
diff --git a/www-client/chromium/files/chromium-83-clang-std.patch b/www-client/chromium/files/chromium-83-clang-std.patch
new file mode 100644 (file)
index 0000000..023a073
--- /dev/null
@@ -0,0 +1,33 @@
+From 93ebdd809b725c7f13e8fc150b3186b3b6d80d43 Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Mon, 30 Mar 2020 16:49:31 +0000
+Subject: [PATCH] libstdc++: fix namespace of nullptr_t in array_buffer_view_helpers.h
+
+nullptr_t is defined in namespace std.
+
+Bug: 819294
+Change-Id: I16fd876b84aff4f3c0ef6d4654b8ad5015e52d27
+---
+
+diff --git a/third_party/blink/renderer/core/typed_arrays/array_buffer_view_helpers.h b/third_party/blink/renderer/core/typed_arrays/array_buffer_view_helpers.h
+index a6b8547..5fa03cb 100644
+--- a/third_party/blink/renderer/core/typed_arrays/array_buffer_view_helpers.h
++++ b/third_party/blink/renderer/core/typed_arrays/array_buffer_view_helpers.h
+@@ -36,7 +36,7 @@
+   template <typename U, std::enable_if_t<std::is_base_of<T, U>::value, int> = 0>
+   NotShared(const NotShared<U>& other) : typed_array_(other.Get()) {}
+-  explicit NotShared(nullptr_t) {}
++  explicit NotShared(std::nullptr_t) {}
+   explicit NotShared(T* typed_array) : typed_array_(typed_array) {
+     DCHECK(!typed_array || !typed_array->IsShared());
+   }
+@@ -95,7 +95,7 @@
+   template <typename U, std::enable_if_t<std::is_base_of<T, U>::value, int> = 0>
+   MaybeShared(const MaybeShared<U>& other) : typed_array_(other.Get()) {}
+-  explicit MaybeShared(nullptr_t) {}
++  explicit MaybeShared(std::nullptr_t) {}
+   // [AllowShared] array buffer view may be a view of non-shared array buffer,
+   // so we don't check if the buffer is SharedArrayBuffer or not.
+   // https://heycam.github.io/webidl/#AllowShared
diff --git a/www-client/chromium/files/chromium-83-gcc-range.patch b/www-client/chromium/files/chromium-83-gcc-range.patch
new file mode 100644 (file)
index 0000000..f8fb287
--- /dev/null
@@ -0,0 +1,28 @@
+From 895f0d24db74516e2653672a4b5e57757eeba75a Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Sun, 29 Mar 2020 21:03:23 +0000
+Subject: [PATCH] GCC: fix out-of-range constant in status_codes.h
+
+Constant 0x99999999 is not within range of int32_t.
+
+Bug: 819294
+Change-Id: I133b9bb0f1f57a6e1d81f96f39f348b6ea1c7f11
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2126227
+Commit-Queue: Ted Meyer <tmathmeyer@chromium.org>
+Reviewed-by: Ted Meyer <tmathmeyer@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#754364}
+---
+
+diff --git a/media/base/status_codes.h b/media/base/status_codes.h
+index ccac030..219defb 100644
+--- a/media/base/status_codes.h
++++ b/media/base/status_codes.h
+@@ -69,7 +69,7 @@
+   kVaapiFailedAcceleratorCreation = 0x00000509,
+   // Special codes
+-  kGenericErrorPleaseRemove = 0x99999999,
++  kGenericErrorPleaseRemove = 0x79999999,
+   kCodeOnlyForTesting = std::numeric_limits<StatusCodeType>::max(),
+   kMaxValue = kCodeOnlyForTesting,
+ };
diff --git a/www-client/chromium/files/chromium-83-gcc-template.patch b/www-client/chromium/files/chromium-83-gcc-template.patch
new file mode 100644 (file)
index 0000000..0c5c20e
--- /dev/null
@@ -0,0 +1,65 @@
+From 7f1503a80edc5ccd73559b227a242eeb9c1bea93 Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Mon, 30 Mar 2020 07:26:49 +0000
+Subject: [PATCH] GCC: fix template specialization in WTF::VectorMover
+
+GCC complains that explicit specialization in non-namespace scope
+is happening for MoveOverlappingImpl. However, secialization is
+not really necessary here with templates and can be moved
+into MoveOverlappingImpl method without changing generated code.
+
+Bug: 819294
+Change-Id: I90b893b9701748302f7b900fbcc2c341685fe0d3
+---
+
+diff --git a/third_party/blink/renderer/platform/wtf/vector.h b/third_party/blink/renderer/platform/wtf/vector.h
+index 632d308..82aaf96 100644
+--- a/third_party/blink/renderer/platform/wtf/vector.h
++++ b/third_party/blink/renderer/platform/wtf/vector.h
+@@ -205,30 +205,23 @@
+     }
+   }
+-  template <bool = Allocator::kIsGarbageCollected>
+-  static void MoveOverlappingImpl(const T* src, const T* src_end, T* dst);
+-  template <>
+-  static void MoveOverlappingImpl<false>(const T* src,
+-                                         const T* src_end,
+-                                         T* dst) {
+-    memmove(dst, src,
+-            reinterpret_cast<const char*>(src_end) -
+-                reinterpret_cast<const char*>(src));
+-  }
+-  template <>
+-  static void MoveOverlappingImpl<true>(const T* src,
+-                                        const T* src_end,
+-                                        T* dst) {
+-    if (src == dst)
+-      return;
+-    if (dst < src) {
+-      for (; src < src_end; ++src, ++dst)
+-        AtomicWriteMemcpy<sizeof(T)>(dst, src);
++  static void MoveOverlappingImpl(const T* src, const T* src_end, T* dst) {
++    if (Allocator::kIsGarbageCollected) {
++      if (src == dst)
++        return;
++      if (dst < src) {
++        for (; src < src_end; ++src, ++dst)
++          AtomicWriteMemcpy<sizeof(T)>(dst, src);
++      } else {
++        --src_end;
++        T* dst_end = dst + (src_end - src);
++        for (; src_end >= src; --src_end, --dst_end)
++          AtomicWriteMemcpy<sizeof(T)>(dst_end, src_end);
++      }
+     } else {
+-      --src_end;
+-      T* dst_end = dst + (src_end - src);
+-      for (; src_end >= src; --src_end, --dst_end)
+-        AtomicWriteMemcpy<sizeof(T)>(dst_end, src_end);
++      memmove(dst, src,
++              reinterpret_cast<const char*>(src_end) -
++                  reinterpret_cast<const char*>(src));
+     }
+   }