games-board/pysolfc: Simplify, remove python-single-r1 inherit
authorDavid Seifert <soap@gentoo.org>
Tue, 6 Sep 2016 19:16:52 +0000 (21:16 +0200)
committerDavid Seifert <soap@gentoo.org>
Tue, 6 Sep 2016 19:17:48 +0000 (21:17 +0200)
Package-Manager: portage-2.3.0

games-board/pysolfc/pysolfc-2.0-r5.ebuild

index 6b7b75260a6759ea66956c957510a1d06d42af19..9dc1ce7e2070ce1174f2d9321386b73248560927 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="tk"
 DISTUTILS_SINGLE_IMPL="1"
 
-inherit eutils python-single-r1 distutils-r1
+inherit eutils distutils-r1
 
 MY_PN=PySolFC
 SOL_URI="mirror://sourceforge/${PN}"
@@ -31,23 +31,12 @@ RDEPEND="${RDEPEND}
                dev-tcltk/tktable )
        sound? ( dev-python/pygame[${PYTHON_USEDEP}] )"
 
-python_prepare_all() {
-       local PATCHES=(
-               "${FILESDIR}/${PN}-PIL-imports.patch" #471514
-               "${FILESDIR}/${PN}-gentoo.patch" #591904
-       )
-
-       distutils-r1_python_prepare_all
-}
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       default
-       distutils-r1_src_prepare
+PATCHES=(
+       "${FILESDIR}/${PN}-PIL-imports.patch" #471514
+       "${FILESDIR}/${PN}-gentoo.patch" #591904
+)
 
+python_prepare_all() {
        sed -i \
                -e "/pysol.desktop/d" \
                -e "s:share/icons:share/pixmaps:" \
@@ -55,10 +44,8 @@ src_prepare() {
                setup.py || die
 
        mv docs/README{,.txt} || die
-}
 
-src_compile() {
-       distutils-r1_src_compile
+       distutils-r1_python_prepare_all
 }
 
 python_install_all() {
@@ -76,7 +63,3 @@ python_install_all() {
 
        distutils-r1_python_install_all
 }
-
-src_install() {
-       distutils-r1_src_install
-}