dev-python/pytest-xprocess: add python 3.7 support
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 01:57:34 +0000 (21:57 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:09:56 +0000 (22:09 -0400)
* EAPI 7
* Fix broken tests

Closes: https://bugs.gentoo.org/644098
Closes: https://bugs.gentoo.org/626328
Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
new file mode 100644 (file)
index 0000000..8677f37
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       dev-python/pytest[${PYTHON_USEDEP}]
+       dev-python/pytest-cache[${PYTHON_USEDEP}]
+       dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+       cd example || die
+       # Upstream's package mistakenly includes __pycache__ directory that make
+       # tests fail.
+       rm -rf __pycache__ || die
+       pytest -v || die
+}