dev-dotnet/libgdiplus: Fix for ld.gold; enhance various QA problems
authorJustin Lecher <jlec@gentoo.org>
Tue, 18 Aug 2015 09:27:20 +0000 (11:27 +0200)
committerJustin Lecher <jlec@gentoo.org>
Tue, 18 Aug 2015 09:27:47 +0000 (11:27 +0200)
* underlinking fix: https://github.com/mono/libgdiplus/pull/33
* drop removed configure option --with-cairo
* call default() functions as often as possible

Gentoo-Bug: https://bugs.gentoo.org/367345

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch [new file with mode: 0644]
dev-dotnet/libgdiplus/libgdiplus-3.12.ebuild

diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch b/dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch
new file mode 100644 (file)
index 0000000..164f994
--- /dev/null
@@ -0,0 +1,17 @@
+ tests/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index fb7aa7e..4d752e1 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -13,7 +13,8 @@ DEPS =                                               \
+ LDADDS =                                      \
+-      $(top_builddir)/src/libgdiplus.la
++      $(top_builddir)/src/libgdiplus.la \
++      -lm
+ noinst_PROGRAMS =                     \
+       testgdi testbits testclip testreversepath
index 5959db39b91763a79f4e10c1c5e17a4dadec3549..96eb910ef869692c4770b0724f055c294f668b33 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-inherit base eutils dotnet flag-o-matic
+
+inherit autotools eutils dotnet flag-o-matic
 
 DESCRIPTION="Library for using System.Drawing with mono"
 HOMEPAGE="http://www.mono-project.com"
@@ -30,38 +31,36 @@ RDEPEND=">=dev-libs/glib-2.2.3:2
        !cairo? ( >=x11-libs/pango-1.20 )"
 DEPEND="${RDEPEND}"
 
-PATCHES=( "${FILESDIR}/${P}-giflib-quantizebuffer.patch"  )
+PATCHES=(
+       "${FILESDIR}/${P}-giflib-quantizebuffer.patch"
+       "${FILESDIR}/${P}-underlinking.patch"
+       )
 
 RESTRICT="test"
 
 src_prepare() {
-       base_src_prepare
-       sed -i -e 's:ungif:gif:g' configure || die
-}
-
-src_configure() {
+       epatch "${PATCHES[@]}"
+       sed -i -e 's:ungif:gif:g' configure.ac || die
        append-flags -fno-strict-aliasing
-       econf   --disable-dependency-tracking           \
-               --disable-static                        \
-               --with-cairo=system                     \
-               $(use !cairo && printf %s --with-pango)
+       eautoreconf
 }
 
-src_compile() {
-       emake "$@"
+src_configure() {
+       econf \
+               --disable-dependency-tracking \
+               --disable-static \
+               $(usex cairo "" "--with-pango")
 }
 
 src_install () {
-       emake -j1 DESTDIR="${D}" "$@" install #nowarn
+       MAKEOPTS+=" -j1"
+       default
+
        dotnet_multilib_comply
        local commondoc=( AUTHORS ChangeLog README TODO )
-       for docfile in "${commondoc[@]}"
-       do
+       for docfile in "${commondoc[@]}"; do
                [[ -e "${docfile}" ]] && dodoc "${docfile}"
        done
-       if [[ "${DOCS[@]}" ]]
-       then
-               dodoc "${DOCS[@]}"
-       fi
+       [[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
        prune_libtool_files
 }