app-emulation/spice-vdagent: version bump to 0.16.0 (bug #554320)
authorMatthias Maier <tamiko@gentoo.org>
Fri, 14 Aug 2015 05:17:55 +0000 (00:17 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Fri, 14 Aug 2015 05:24:28 +0000 (00:24 -0500)
This version bump also addresses

 - update dependency on app-emulation/spice-protocol
 - install systemd unit files
 - support for systemd session-info support via systemd use flag, bug #485334
 - remove keepdir /var/run, bug #453042

Gentoo-Bug: 453042
Gentoo-Bug: 485334
Gentoo-Bug: 554320

Package-Manager: portage-2.2.20.1

app-emulation/spice-vdagent/Manifest
app-emulation/spice-vdagent/spice-vdagent-0.16.0.ebuild [new file with mode: 0644]

index a89f6379b263e0edf372a50e7223acb9bf5a1541..56b53cbd88fea409ef03b01a78b2035c9375e7c9 100644 (file)
@@ -1,3 +1,4 @@
 DIST spice-vdagent-0.10.1.tar.bz2 107250 SHA256 cea0db6f2def79a96876d0921f2a6234875797c68a8143d24cf9af8cc01361db SHA512 b7a42af7fd1d15dcfd618be34b99c73fa2d07105e37236a5a8c2a0b70d7d112de9e99200257ae746f60de583735681ce7c1437445921f6b8a877c7a9b2083afe WHIRLPOOL 83f3f6b2501966a0a5b053547759fd8a131d3e6a795f008c21f0a11794fd6ae7e30800328189e4dead11c19ae2a0a08a35ff192011622ca2fa8eac204711d035
 DIST spice-vdagent-0.12.0.tar.bz2 114252 SHA256 e0bee1985c2c31ccc44043ed6735304078e09e14c4f805962cf8c288fa205659 SHA512 42c98a3cc3167884203d4d0a31562668be3df10c89eca2a9257c6de1f787b7db77f0648013f307554eb09c0bf3f0cddc8632f050c4018aef544b9c22a02b2dfe WHIRLPOOL 3e00f0ac9ca66a2c6fec4307d4b6eea51fc4a266e72e6d5764e8f3fb01ab407440cabe20ee1db4d9703e5bda5d66616f71a8baa1d8d6610b0e1c75a67b3affae
+DIST spice-vdagent-0.16.0.tar.bz2 128174 SHA256 5b951646e0bd996afda2d063e706fa2aad2655af5bdd1b6525260ab50be30f7d SHA512 033fe60f152daceb05b51963b78daf6f757d0ad26398f47479c957c5c0f1735e26019c05ef30e485317ba75dd1a57ee1bffbab20eb2c46614d88ed7401795a97 WHIRLPOOL b94a60e15eb0ea107e974ad68bd07296eec9e08840afb2e57da64b35f26a613637975791e1a615af260acf9345ec016564ab15d96a00443665b5d1880b267d71
 DIST spice-vdagent-0.8.1.tar.bz2 98437 SHA256 99ec232805a6201da78d409e6f874ff0aa6bb25e7ffe623aa77752539ae7d7ff SHA512 45c2b94dc66dd2061b57cfe90d7b900fd095fa067c6bca560ecc300979953e8c37b63e8cbdb4683275a1cc084512aa97e1125bbb17e39a6966387e4f1be2c178 WHIRLPOOL 1cfeabc97f4c1fd9e42a9ad849916f04d9f4f640a586158c3d8b2ab3b9449f6e1cf8acba196a9e684a1499404747971fa82ad922bd50e87c257526d67468a85f
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.16.0.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.16.0.ebuild
new file mode 100644 (file)
index 0000000..b652156
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="SPICE VD Linux Guest Agent"
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+consolekit selinux systemd"
+
+CDEPEND="media-libs/alsa-lib
+       x11-libs/libXfixes
+       x11-libs/libXrandr
+       x11-libs/libX11
+       x11-libs/libXinerama
+       >=x11-libs/libpciaccess-0.10
+       >=app-emulation/spice-protocol-0.12.8
+       consolekit? ( sys-auth/consolekit sys-apps/dbus )
+       systemd? ( sys-apps/systemd )"
+DEPEND="virtual/pkgconfig
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-vdagent )"
+
+CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
+ERROR_INPUT_UINPUT="User level input support is required"
+ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support is required"
+
+src_configure() {
+       local opt="--with-session-info=none --with-init-script=systemd"
+
+       use systemd && opt="--with-session-info=systemd"
+       use consolekit && opt="${opt} --with-session-info=console-kit"
+
+       econf \
+               --localstatedir=/var \
+               ${opt}
+}
+
+src_install() {
+       default
+
+       rm -rf "${D}"/etc/{rc,tmpfiles}.d
+
+       keepdir /var/log/spice-vdagentd
+
+       newinitd "${FILESDIR}/${PN}.initd-2" "${PN}"
+       newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
+}