dev-python/pyqtgraph: bump to 0.11.0_rc0 and EAPI-7
authorMarek Szuba <marecki@gentoo.org>
Fri, 24 Apr 2020 15:42:23 +0000 (16:42 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 24 Apr 2020 22:56:18 +0000 (23:56 +0100)
The only version to date with python3_8 support. Ostensibly a release
candidate but if it's good enough for Debian to package then it's good
enough for me!

Committed with kind permission of mgorny on behalf of the Python
project.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-python/pyqtgraph/Manifest
dev-python/pyqtgraph/files/pyqtgraph-0.11.0-qt5_only.patch [new file with mode: 0644]
dev-python/pyqtgraph/pyqtgraph-0.11.0_rc0.ebuild [new file with mode: 0644]

index ae3b55682a0e2bfdbad55357a5f221312c274389..5b078024ea79d1161fa0c1fd4d19b9c16d4b6522 100644 (file)
@@ -1 +1,2 @@
 DIST pyqtgraph-0.10.0.tar.gz 704972 BLAKE2B cb1295608536b06de32ea72503b2df2be7f4ae3065b42431542539feec5eb37412e3a7697e2ee97309594b9aecc19c692ef7b45f843f37bd50148a3c0b6e1d31 SHA512 d995da7b4f13ae0009582aebe3f753dc78566dc50ba9314d3a2d37ad4ed8f2fd8bb497a01bb8b37b6d96bf14c071aad018bcbc7224d9dd9b47589a7b5b640d30
+DIST pyqtgraph-0.11.0_rc0.tar.gz 755973 BLAKE2B 845c57a16c71d449419cca452ac70468eb21f198b3aebe39204e8ac1408ebd4471a95b24cbd91cd4c745439c17a805738e50a29f8690de5d84f86c2597310aea SHA512 6eb5573b19c7fc0bc263bdc5d75a9a7a5d86d5ce525e406fcbd8f4215a8b2a0a9a7d4839d177fb10ff62a5feacdf088347828900daa9f60ae84e54824b98f470
diff --git a/dev-python/pyqtgraph/files/pyqtgraph-0.11.0-qt5_only.patch b/dev-python/pyqtgraph/files/pyqtgraph-0.11.0-qt5_only.patch
new file mode 100644 (file)
index 0000000..1e65b0d
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/pyqtgraph/Qt.py
++++ b/pyqtgraph/Qt.py
+@@ -25,7 +25,7 @@
+ ## This is done by first checking to see whether one of the libraries
+ ## is already imported. If not, then attempt to import PyQt4, then PySide.
+ if QT_LIB is None:
+-    libOrder = [PYQT4, PYSIDE, PYQT5, PYSIDE2]
++    libOrder = [PYQT5]
+     for lib in libOrder:
+         if lib in sys.modules:
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.11.0_rc0.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.11.0_rc0.ebuild
new file mode 100644 (file)
index 0000000..f13ada1
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+MY_PV=$(ver_rs 3 "")
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="http://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl svg"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+       sci-libs/scipy[${PYTHON_USEDEP}]
+       dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+       opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.11.0-qt5_only.patch
+)
+
+DOCS=( CHANGELOG README.md )
+
+S="${WORKDIR}"/${PN}-${MY_P}
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+
+       if ! use opengl; then
+               rm -r pyqtgraph/opengl || die
+       fi
+}
+
+python_install_all() {
+       use examples && DOCS+=( examples/ )
+       distutils-r1_python_install_all
+}