dev-libs/aws-checksums: HW accelerated CRC32c and CRC32 with fallbacks
authorSven Eden <yamakuzure@gmx.net>
Thu, 15 Aug 2019 16:21:00 +0000 (18:21 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 20 Sep 2019 15:23:33 +0000 (18:23 +0300)
Cross-Platform HW accelerated CRC32c and CRC32 with fallback to
efficient SW implementations. C interface with language bindings for
each of our SDKs

Dependency for dev-libs/aws-sdk-cpp-1.7.178

Signed-off-by: Sven Eden <yamakuzure@gmx.net>
Bug: https://bugs.gentoo.org/666494
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/aws-checksums/Manifest [new file with mode: 0644]
dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild [new file with mode: 0644]
dev-libs/aws-checksums/metadata.xml [new file with mode: 0644]

diff --git a/dev-libs/aws-checksums/Manifest b/dev-libs/aws-checksums/Manifest
new file mode 100644 (file)
index 0000000..257865b
--- /dev/null
@@ -0,0 +1 @@
+DIST aws-checksums-0.1.3.tar.gz 78242 BLAKE2B e78f3bb34e124351ad494e86e579613799afebcfe491fb36b20190121f2bf9de9d96714ad304a7fcd702708f5be417c6dbafe65606b2fe42c340edc796a3ecf3 SHA512 79bf71a6c4c268b27efe8a6a3c4b90281da4ce7f6e4c1c62fce80b11a4756ecfd4dc2b19624ace3f54137113d0cb56a517de0b91dd6338ee8ca069756bca13f4
diff --git a/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild b/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
new file mode 100644 (file)
index 0000000..cb764ee
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Cross-Platform HW accelerated CRC32c and CRC32 with software fallbacks"
+HOMEPAGE="https://github.com/awslabs/aws-checksums"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_TESTING=$(usex test)
+       )
+       cmake-utils_src_configure
+}
diff --git a/dev-libs/aws-checksums/metadata.xml b/dev-libs/aws-checksums/metadata.xml
new file mode 100644 (file)
index 0000000..d0278a7
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>yamakuzure@gmx.net</email>
+               <name>Sven Eden</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               Cross-Platform HW accelerated CRC32c and CRC32 with fallback to
+               efficient SW implementations. C interface with language
+               bindings for each of our SDKs
+       </longdescription>
+</pkgmetadata>