net-im/skypeforlinux: Version bump to 8.59.0.77
authorDavid Seifert <soap@gentoo.org>
Thu, 16 Apr 2020 11:10:09 +0000 (13:10 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 16 Apr 2020 11:10:09 +0000 (13:10 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: David Seifert <soap@gentoo.org>
net-im/skypeforlinux/Manifest
net-im/skypeforlinux/skypeforlinux-8.59.0.77.ebuild [new file with mode: 0644]

index 3e5395d9807d97f711a4c3b022b45b35f97540c1..3277dbf5cd942c13908beea73a4c99637a190460 100644 (file)
@@ -1,2 +1,3 @@
 DIST skypeforlinux_8.57.0.116-1.x86_64.rpm 107397354 BLAKE2B 22d1b41201087b3067e89e583734f0b195103dff52f2023e5cc812a977338f2af7eafe5e82bd3f34e263740a1c2791035ee6b75dc077865fa14f1dcc1189b9a6 SHA512 79b5019be9c4cdb28c3dd166aa76128385631e1bc4e31f0b0bfdb0c7af54494987faf4ab3ed05dc9f810b05e07de916d997d5fe4c722aff089e00789394ef3d3
 DIST skypeforlinux_8.58.0.93-1.x86_64.rpm 108966411 BLAKE2B b74dfe1758fbec9e000be7134d1b575a28077967c95b18955c6b90ac9b3bba1b69b19f91553185939f0e39a1ff80fa26020a383a42940c729d6256df01cf74cc SHA512 907159ac1fead3248114a9bf67a764df9f3ec7deb1b9008b6228d55deacbc6ee150e8496674a484c5be14a59ab33c163493b704c364c822177827fcacfba0452
+DIST skypeforlinux_8.59.0.77-1.x86_64.rpm 108914465 BLAKE2B 9d8300b9d315b95528e7e453a4b2175a22cc598634f0b517e6e0b45dfd7c04d6cee92d46d455486ee00ea1953617132e6c97576d5cc344988912aa3df03609e8 SHA512 4faa158605c13ee66bf49aad8e1b06f0429772c676088559fb28f6012cf263c1425f830678edd9605cfd69a4a0fb75f051fd96acd0a8a4fb636bb3a5beceb211
diff --git a/net-im/skypeforlinux/skypeforlinux-8.59.0.77.ebuild b/net-im/skypeforlinux/skypeforlinux-8.59.0.77.ebuild
new file mode 100644 (file)
index 0000000..c2755ee
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+       app-crypt/libsecret[${MULTILIB_USEDEP}]
+       dev-libs/atk[${MULTILIB_USEDEP}]
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       dev-libs/glib:2[${MULTILIB_USEDEP}]
+       dev-libs/nspr[${MULTILIB_USEDEP}]
+       dev-libs/nss[${MULTILIB_USEDEP}]
+       media-libs/alsa-lib[${MULTILIB_USEDEP}]
+       media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+       media-libs/freetype:2[${MULTILIB_USEDEP}]
+       media-libs/libv4l[${MULTILIB_USEDEP}]
+       net-print/cups[${MULTILIB_USEDEP}]
+       sys-apps/dbus[${MULTILIB_USEDEP}]
+       sys-devel/gcc[cxx]
+       virtual/ttf-fonts
+       x11-libs/cairo[${MULTILIB_USEDEP}]
+       x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+       x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+       x11-libs/libX11[${MULTILIB_USEDEP}]
+       x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+       x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+       x11-libs/libXcursor[${MULTILIB_USEDEP}]
+       x11-libs/libXdamage[${MULTILIB_USEDEP}]
+       x11-libs/libXext[${MULTILIB_USEDEP}]
+       x11-libs/libXfixes[${MULTILIB_USEDEP}]
+       x11-libs/libXi[${MULTILIB_USEDEP}]
+       x11-libs/libXrandr[${MULTILIB_USEDEP}]
+       x11-libs/libXrender[${MULTILIB_USEDEP}]
+       x11-libs/libXtst[${MULTILIB_USEDEP}]
+       x11-libs/libxcb[${MULTILIB_USEDEP}]
+       x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+       x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+       chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+       rpm_src_unpack ${A}
+}
+
+src_prepare() {
+       default
+       sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+               -i usr/bin/skypeforlinux || die
+       sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+               -e "/^OnlyShowIn=/d" \
+               -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+       dodir /opt
+       cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+       # remove chrome-sandbox binary, users should use kernel namespaces
+       # https://bugs.gentoo.org/692692#c18
+       rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+       dobin usr/bin/skypeforlinux
+
+       dodoc usr/share/skypeforlinux/*.html
+       dodoc -r usr/share/doc/skypeforlinux/.
+       # symlink required for the "Help->3rd Party Notes" menu entry  (otherwise frozen skype -> xdg-open)
+       dosym ${PF} usr/share/doc/skypeforlinux
+
+       doicon usr/share/pixmaps/skypeforlinux.png
+
+       local res
+       for res in 16 32 256 512; do
+               newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+       done
+
+       domenu usr/share/applications/skypeforlinux.desktop
+
+       pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+       pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}