Changed dep to virtual/perl-Time-HiRes. Also switched from fowners/fperms to chown...
authorWilliam Thomson <wltjr@gentoo.org>
Wed, 10 Jan 2007 17:08:48 +0000 (17:08 +0000)
committerWilliam Thomson <wltjr@gentoo.org>
Wed, 10 Jan 2007 17:08:48 +0000 (17:08 +0000)
Package-Manager: portage-2.1.2_rc4-r6

mail-filter/assp/ChangeLog
mail-filter/assp/assp-1.2.5-r5.ebuild [new file with mode: 0644]
mail-filter/assp/files/digest-assp-1.2.5-r5 [new file with mode: 0644]

index b81cf15d1d55a49674ba613d76e6bd3019cd3182..ada7b16c419696a6342f52338625fa09c67ebd1e 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for mail-filter/assp
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/assp/ChangeLog,v 1.6 2006/11/22 19:00:28 wltjr Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/assp/ChangeLog,v 1.7 2007/01/10 17:08:48 wltjr Exp $
+
+*assp-1.2.5-r5 (10 Jan 2007)
+
+  10 Jan 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+  -assp-1.2.5-r3.ebuild, -assp-1.2.5-r4.ebuild, +assp-1.2.5-r5.ebuild:
+  Changed dep to virtual/perl-Time-HiRes. Also switched from fowners/fperms to
+  chown/chmod due to perms not be corrected/adjusted if dirs already exist
+  with diff owner/perms
 
 *assp-1.2.5-r4 (22 Nov 2006)
 
diff --git a/mail-filter/assp/assp-1.2.5-r5.ebuild b/mail-filter/assp/assp-1.2.5-r5.ebuild
new file mode 100644 (file)
index 0000000..edf4386
--- /dev/null
@@ -0,0 +1,121 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/assp/assp-1.2.5-r5.ebuild,v 1.1 2007/01/10 17:08:48 wltjr Exp $
+
+inherit eutils
+
+DESCRIPTION="Anti-Spam SMTP Proxy written in Perl."
+HOMEPAGE="http://assp.sourceforge.net/"
+MY_PN=ASSP
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_${PV}-Install.zip"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ldap spf srs"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND="dev-lang/perl
+       dev-perl/Net-DNS
+       dev-perl/File-ReadBackwards
+       dev-perl/Compress-Zlib
+       dev-perl/Email-Valid
+       virtual/perl-Digest-MD5
+       virtual/perl-Time-HiRes
+       spf? ( dev-perl/Mail-SPF-Query )
+       srs? ( dev-perl/Mail-SRS )
+       ldap? ( dev-perl/perl-ldap )"
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+       enewgroup assp
+       enewuser assp -1 -1 /dev/null assp
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch ${FILESDIR}/assp-${PV}.patch
+
+       local FILES="
+               assp.pl
+               freshclam.sh
+               move2num.pl
+               rebuildspamdb.pl
+               repair.pl
+               stats.sh
+               stat.pl
+       "
+       # just being safe
+       for file in ${FILES}; do
+               edos2unix ${file}
+       done
+
+       # remove windows stuff
+       rm "${S}/addservice.pl"
+       rm -f "${S}/Win32-quickstart-guide.txt"
+}
+
+src_install() {
+       # Configuration directory
+       dodir /etc/assp
+       chown assp:assp /etc/assp
+       chmod 770 /etc/assp
+
+       # Setup directories for mail to be stored for filter
+       keepdir /var/lib/assp/spam /var/lib/assp/notspam
+       keepdir /var/lib/assp/errors/spam /var/lib/assp/errors/notspam
+
+       # Logs directory
+       keepdir /var/log/assp
+       chown assp:assp -R /var/log/assp
+       chmod 770 /var/log/assp
+
+       # Install the app
+       exeinto /usr/share/assp
+       doexe *.pl *.sh
+       insinto /usr/share/assp
+       doins -r images/
+       insinto /var/lib/assp
+       doins *.txt *.sav
+
+       # Lock down the files/data
+       chown assp:assp -R /usr/share/assp
+       chmod 770 /usr/share/assp
+
+       # Data storage
+       chown assp:assp -R /var/lib/assp
+       chmod 770 /var/lib/assp
+
+       # PID directory
+       dodir /var/run/assp
+       keepdir /var/run/assp
+       chown assp:assp -R /var/run/assp
+       chmod 770 /var/run/assp
+
+       # Install the init.d script to listen
+       newinitd "${FILESDIR}/asspd.init" asspd
+
+       dohtml *.htm
+}
+
+pkg_postinst() {
+       elog
+       elog "To configure ASSP, start /etc/init.d/asspd then point"
+       elog "your browser to http://localhost:55555"
+       elog "Username: admin  Password: nospam4me (CHANGE ASAP!)"
+       elog
+       elog "File permissions have been set to use assp:assp"
+       elog "with mode 770 on directories.  When you configure"
+       elog "ASSP, make sure and use the user assp."
+       elog
+       elog "Don't change any path related options."
+       elog
+       elog "All utilities are prefixed with assp."
+       elog
+       elog "See the on-line docs for a complete tutorial."
+       elog
+}
diff --git a/mail-filter/assp/files/digest-assp-1.2.5-r5 b/mail-filter/assp/files/digest-assp-1.2.5-r5
new file mode 100644 (file)
index 0000000..b1a9662
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ffbb815b24ea5073000dd50143edc311 ASSP_1.2.5-Install.zip 244225
+RMD160 748798f39918e6519be755d8e44a288fc82d636c ASSP_1.2.5-Install.zip 244225
+SHA256 282325e0434ef8554fe281a2b25267fde99254ea83bc7073c2acfbc47c2d31af ASSP_1.2.5-Install.zip 244225