dev-libs/libsavitar: version bump to 4.6.1
authorMichael Perlov <perlovka@gmail.com>
Fri, 22 May 2020 00:50:06 +0000 (03:50 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Mon, 25 May 2020 19:41:03 +0000 (22:41 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Michael Perlov <perlovka@gmail.com>
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-libs/libsavitar/Manifest
dev-libs/libsavitar/files/libsavitar-4.6.1-remove-packaged-pugixml.patch [new file with mode: 0644]
dev-libs/libsavitar/libsavitar-4.6.1.ebuild [new file with mode: 0644]

index de4dfc57d7007a7134165a221182f3dfe4e9d369..a4c6a4380d0acb8ca2572ce6a36c50c41957cd48 100644 (file)
@@ -2,3 +2,4 @@ DIST libsavitar-3.4.1.tar.gz 92457 BLAKE2B ef5b7bb87d7b3293c0634d510f860b64f3235
 DIST libsavitar-3.6.0.tar.gz 92456 BLAKE2B badd2e416015c2d3331cfe77840466f11f2b671821474b78fff084c4f1c3bebab7b2ae16f75918d4eb40996e293165be46f98efea20edc57b1e1255c2ea9fed0 SHA512 6d7c416218a69b1327ed211a9b198cdfb6ebdf1fc9c8c76b898882a63d0905521d5e41380b21f0b8100ab3e3474bbbf142adea29c6643f03bc3f8c3e6ec3c72f
 DIST libsavitar-4.2.0.tar.gz 96223 BLAKE2B bfb41111e8c7cd90acec28bcb11874fc39d6fa2d0785959fd020fb36949300a0e1517a4ed78a153b1f1576b6603a466a2f5baa7e8370b05311729e17b7e83566 SHA512 9d1ee73b8e29e1b8b5688c309471cb6053addce351df8deb4e0cb46d15ffc8fe764216c9abd603440b6a60f42379fa03d88e8023ed01502c4e905ebc6a4f393d
 DIST libsavitar-4.3.0.tar.gz 96154 BLAKE2B 866edadad2ea27002b79e018dc073f53409e5fc3af86941ca3e196ab0c8e7299f945997801126b79776538abe81af3abec5c116dac9eb977c1fac02fa45767b4 SHA512 4accce4a96deddfe148540c3abb3cba391178ffc34b88ea77e07053c36eb2c3d6aa7b040ec386ba5bb2eb9e6d9c371b5c35fae268f953694f6ccd9e6c82223d6
+DIST libsavitar-4.6.1.tar.gz 98202 BLAKE2B 8025d11316fb777a037c01fb9411a6368e5e7a1b64c4a695a114ff94c1a2802d4eaeb6c8512e14db74ddbbffabd2bc98f93f61adfc2cbdc7ef329d30b105bd4b SHA512 49a0f2e98bc26d84b638d6eb44f9fd93811d92ad398f3c85b1abf2cca3172667315b907d30807eb70b497bd652d95cd443c8cc4daa68c8852787ef46fda47cc2
diff --git a/dev-libs/libsavitar/files/libsavitar-4.6.1-remove-packaged-pugixml.patch b/dev-libs/libsavitar/files/libsavitar-4.6.1-remove-packaged-pugixml.patch
new file mode 100644 (file)
index 0000000..b1b7746
--- /dev/null
@@ -0,0 +1,60 @@
+diff -urN libSavitar-4.2.0_old/CMakeLists.txt libSavitar-4.2.0/CMakeLists.txt
+--- libSavitar-4.2.0_old/CMakeLists.txt        2019-07-30 09:03:53.000000000 +0300
++++ libSavitar-4.2.0/CMakeLists.txt    2019-08-04 17:23:27.099395645 +0300
+@@ -15,7 +15,7 @@
+     find_package(Threads QUIET)
+ endif()
+-add_subdirectory(pugixml)
++find_package(pugixml REQUIRED)
+ if(BUILD_PYTHON)
+     list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+diff -urN libSavitar-4.2.0_old/src/MeshData.cpp libSavitar-4.2.0/src/MeshData.cpp
+--- libSavitar-4.2.0_old/src/MeshData.cpp      2019-07-30 09:03:53.000000000 +0300
++++ libSavitar-4.2.0/src/MeshData.cpp  2019-08-04 17:23:59.891051757 +0300
+@@ -17,7 +17,7 @@
+  */
+ #include "MeshData.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <cstring>
+ #include <iostream>
+ #include <stdexcept> //For std::runtime_error.
+diff -urN libSavitar-4.2.0_old/src/Scene.cpp libSavitar-4.2.0/src/Scene.cpp
+--- libSavitar-4.2.0_old/src/Scene.cpp 2019-07-30 09:03:53.000000000 +0300
++++ libSavitar-4.2.0/src/Scene.cpp     2019-08-04 17:24:10.425265944 +0300
+@@ -17,7 +17,7 @@
+  */
+ #include "Scene.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <iostream>
+ #include <string>
+ using namespace Savitar;
+diff -urN libSavitar-4.2.0_old/src/SceneNode.cpp libSavitar-4.2.0/src/SceneNode.cpp
+--- libSavitar-4.2.0_old/src/SceneNode.cpp     2019-07-30 09:03:53.000000000 +0300
++++ libSavitar-4.2.0/src/SceneNode.cpp 2019-08-04 17:24:31.617696840 +0300
+@@ -18,7 +18,7 @@
+ #include "SceneNode.h"
+ #include "Namespace.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <iostream>
+ using namespace Savitar;
+diff -urN libSavitar-4.2.0_old/src/ThreeMFParser.h libSavitar-4.2.0/src/ThreeMFParser.h
+--- libSavitar-4.2.0_old/src/ThreeMFParser.h   2019-07-30 09:03:53.000000000 +0300
++++ libSavitar-4.2.0/src/ThreeMFParser.h       2019-08-04 17:24:53.996151843 +0300
+@@ -21,7 +21,7 @@
+ #include "SavitarExport.h"
+ #include "SceneNode.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <string>
+ namespace Savitar
diff --git a/dev-libs/libsavitar/libsavitar-4.6.1.ebuild b/dev-libs/libsavitar/libsavitar-4.6.1.ebuild
new file mode 100644 (file)
index 0000000..8c07045
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake python-single-r1
+
+MY_PN="libSavitar"
+
+DESCRIPTION="C++ implementation of 3mf loading with SIP python bindings"
+HOMEPAGE="https://github.com/Ultimaker/libSavitar"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+       dev-libs/pugixml
+       $(python_gen_cond_dep '
+               dev-python/sip[${PYTHON_MULTI_USEDEP}]
+       ')"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.6.1-remove-packaged-pugixml.patch )
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       # Find SIP for current python version, not the latest installed
+       sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" \
+               CMakeLists.txt || die
+       sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" \
+               cmake/FindSIP.cmake || die
+
+       cmake_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_PYTHON=$(usex python ON OFF)
+               -DBUILD_STATIC=$(usex static-libs ON OFF)
+       )
+
+       cmake_src_configure
+}