app-admin/puppet: bup
authorMatthew Thode <mthode@mthode.org>
Tue, 15 Sep 2015 18:34:29 +0000 (13:34 -0500)
committerMatthew Thode <mthode@mthode.org>
Tue, 15 Sep 2015 18:34:29 +0000 (13:34 -0500)
Package-Manager: portage-2.2.20.1

app-admin/puppet/Manifest
app-admin/puppet/puppet-4.2.2.ebuild [new file with mode: 0644]

index f21dfeaec8eeec549a178a3780a9db4cd20cf65f..10ce1060ab1dd555c90d4f84a94e32f0eeb95e69 100644 (file)
@@ -5,3 +5,4 @@ DIST puppet-3.8.2.tar.gz 2637591 SHA256 5a89c623f22fc96a2919801ff874b10f8f1a66e9
 DIST puppet-4.0.0.tar.gz 2498445 SHA256 c02a5cceb68d6c26228c242a312d68cf054233842e914e9d3aec32b38034e013 SHA512 c8ec0771105e83498f7558e1dfa8679d94cb2d526589041319f35cce214a4c8602ebf8541a15fa64ce542168d101042153815887fb8350bce0c4371c490f396f WHIRLPOOL af53d8b14b7110e6648873e9822de37a8bb17b7f635800d9a9fb1fff7df22000cd13604b45913ddddbae58b7af198c80e84c001cc8b6d1643db9ead4ece42bb7
 DIST puppet-4.1.0.tar.gz 2532579 SHA256 a168ac45a7b25932dfc78bd5da3efe41363e239c7361dd5c4f91615dc17bb275 SHA512 85ba32fb3a7e9f3413f201263943411fbb6b57a4aa13461954b32c1095b06d04f26288a216c5624290cf89d09183bc86bb5f57769fe2ccadc44bf57cd601f5d3 WHIRLPOOL 5288b3204a5c5b96da4eabdee19c1156e71b3a76662d8d28fc8e43988e76ca52618d423c207c1a25d5d92638c559db76ee3c8ce336286d3a5e875c1dc538f8b8
 DIST puppet-4.2.1.tar.gz 2546267 SHA256 519842dfa03ff78c94e77fb28867aef12933691b9e2ce41788f80c5c2865fe7e SHA512 d4ce3f6cd0fbca4270a9121671c27985c9aaa5360a1a317afcc8f79cd81d285e1661cc77d50dda47abd8e50309762d5931545ea4d675b9fb6c32b612e570fd3d WHIRLPOOL 492294158f7f5eb78b93098c759c97ca53a09fc7b24a8350dfd76220a1d578f78375ba3bd9d618b97299931001af83cc5475c4f6ad9bbb1c3d9744fa07585bfd
+DIST puppet-4.2.2.tar.gz 2550591 SHA256 2d34cda2c65c885ba16e6644edd7733d55e6a0e1011a1f0f7fe80b411affc348 SHA512 63fdbce7839fe1638c22129d22bf2aeef29838adceb6c53aaaf54acc7c9d2957ed559e3625a13dfa1f35b556791de0232868f5ecdc439be95b0b64bea097d217 WHIRLPOOL e2f579efbfc3fbab35ee3a23f40a396b0326484c935eaacead503848abc8406fe705701a2ab7eaf28e070feedef7ac4467d4bbf3412f5999091c809c88550c4c
diff --git a/app-admin/puppet/puppet-4.2.2.ebuild b/app-admin/puppet/puppet-4.2.2.ebuild
new file mode 100644 (file)
index 0000000..68a3870
--- /dev/null
@@ -0,0 +1,175 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax xemacs"
+RESTRICT="test"
+
+ruby_add_rdepend "
+       dev-ruby/hiera
+       >=dev-ruby/rgen-0.6.5 =dev-ruby/rgen-0.6*
+       dev-ruby/json
+       >=dev-ruby/facter-3.0.0
+       augeas? ( dev-ruby/ruby-augeas )
+       diff? ( dev-ruby/diff-lcs )
+       doc? ( dev-ruby/rdoc )
+       ldap? ( dev-ruby/ruby-ldap )
+       shadow? ( dev-ruby/ruby-shadow )
+       sqlite? ( dev-ruby/sqlite3 )
+       virtual/ruby-ssl"
+
+ruby_add_bdepend "
+       test? (
+               dev-ruby/mocha
+               dev-ruby/rack
+               dev-ruby/rspec-its
+       )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+#              dev-ruby/rspec-collection_matchers
+
+DEPEND+=" ${DEPEND}
+       emacs? ( virtual/emacs )
+       xemacs? ( app-editors/xemacs )"
+RDEPEND+=" ${RDEPEND}
+       rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+       selinux? (
+               sys-libs/libselinux[ruby]
+               sec-policy/selinux-puppet
+       )
+       vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+       >=app-portage/eix-0.18.0"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+       enewgroup puppet
+       enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+       # Avoid spec that require unpackaged json-schema.
+       rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+       # can't be run within portage.
+       epatch "${FILESDIR}/puppet-fix-tests-4.x.patch"
+
+       # Avoid specs that can only run in the puppet.git repository. This
+       # should be narrowed down to the specific specs.
+       rm spec/integration/parser/compiler_spec.rb || die
+
+       # Avoid failing spec that need further investigation.
+       rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+all_ruby_compile() {
+       if use emacs ; then
+               elisp-compile ext/emacs/puppet-mode.el
+       fi
+
+       if use xemacs ; then
+               # Create a separate version for xemacs to be able to install
+               # emacs and xemacs in parallel.
+               mkdir ext/xemacs
+               cp ext/emacs/* ext/xemacs/
+               xemacs-elisp-compile ext/xemacs/puppet-mode.el
+       fi
+}
+
+each_ruby_install() {
+       each_fakegem_install
+#      dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+       all_fakegem_install
+
+       # systemd stuffs
+       insinto /usr/lib/systemd/system
+       doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+       # tmpfiles stuff
+       insinto /usr/lib/tmpfiles.d
+       newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+       # openrc init stuff
+       newinitd "${FILESDIR}"/puppet.init-4.x puppet
+       newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+       newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+       keepdir /etc/puppetlabs/puppet/ssl
+
+       keepdir /var/lib/puppet/facts
+       keepdir /var/lib/puppet/files
+       fowners -R puppet:puppet /var/lib/puppet
+
+       fperms 0750 /var/lib/puppet
+
+       fperms 0750 /etc/puppetlabs
+       fperms 0750 /etc/puppetlabs/puppet
+       fperms 0750 /etc/puppetlabs/puppet/ssl
+       fowners -R :puppet /etc/puppetlabs
+       fowners -R :puppet /var/lib/puppet
+
+       if use emacs ; then
+               elisp-install ${PN} ext/emacs/puppet-mode.el*
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       fi
+
+       if use xemacs ; then
+               xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
+               xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       fi
+
+       if use ldap ; then
+               insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+       fi
+
+       # ext and examples files
+       for f in $(find ext examples -type f) ; do
+               docinto "$(dirname ${f})"; dodoc "${f}"
+       done
+}
+
+pkg_postinst() {
+       elog
+       elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+       elog "cause puppet to hang while installing packages."
+       elog
+       elog "Portage Puppet module with Gentoo-specific resources:"
+       elog "http://forge.puppetlabs.com/gentoo/portage"
+       elog
+
+       if [ "$(get_major_version $REPLACING_VERSIONS)" = "3" ]; then
+               elog
+               elog "If you're upgrading from 3.x then please move everything in /etc/puppet to"
+               elog "/etc/puppetlabs/puppet"
+               elog "Also, puppet now uses config directories for modules and manifests."
+               elog "See https://docs.puppetlabs.com/puppet/4.0/reference/upgrade_agent.html"
+               elog "and https://docs.puppetlabs.com/puppet/4.0/reference/upgrade_server.html"
+               elog "for more information."
+               elog
+       fi
+
+       use emacs && elisp-site-regen
+       use xemacs && xemacs-elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+       use xemacs && xemacs-elisp-site-regen
+}