media-sound/lilypond: bump to 2.21.1 + 9999 sync
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 8 May 2020 09:51:45 +0000 (11:51 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 8 May 2020 09:54:29 +0000 (11:54 +0200)
Closes: https://bugs.gentoo.org/629686
Closes: https://bugs.gentoo.org/720422
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/lilypond/Manifest
media-sound/lilypond/files/lilypond-2.21.1-fix-font-size.patch [new file with mode: 0644]
media-sound/lilypond/lilypond-2.21.1.ebuild [new file with mode: 0644]
media-sound/lilypond/lilypond-9999.ebuild

index dfbd54447466ec1a4ce79bf8c08d07badb42770a..6e142f16da35277ef78599ecff3e4f46b8056e64 100644 (file)
@@ -1,2 +1,3 @@
 DIST lilypond-2.18.2.tar.gz 16027977 BLAKE2B b19b608891e22403efe8e18dd9e86c8d0c85ba516f34242f2a8bcb53c8849a3aa0fe83726036d168f26ee1a7d868a24cc54bd86016b016d634218956e8faf0d4 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6
 DIST lilypond-2.19.83.tar.gz 17996428 BLAKE2B d6048bfa0dbfbb08c25c5c11287f971936e82d30d88d80deb7fca8fe8d7c8d3d517c37a24b1d52e592c15e166e04eb79d99b4c64ddd4b7f392ec69bff0259d89 SHA512 c8a6acbff055196aba015ecd4786bed25934f04f3718ae9dd9a0dc49d2954f348806874cfe350903cd8bb2b25a0d05700ef5947cac180b20a8a355033ff98604
+DIST lilypond-2.21.1.tar.gz 18135688 BLAKE2B 4a797c325e254b59cb314b28a801198f398efd7a37cac448b79d8161ab7248b0c9ca45ce742b82d0aebb784a98637209c84df74304a9e8c8f744b9f5033e18d2 SHA512 596f6a09d0f9a0c39ca717a9e4e246e03679a6cf40a78491eac9bc3eccf173799c75a0baef491cae8385bf1abda53244fd731695762b6fd841396edb92d0ab75
diff --git a/media-sound/lilypond/files/lilypond-2.21.1-fix-font-size.patch b/media-sound/lilypond/files/lilypond-2.21.1-fix-font-size.patch
new file mode 100644 (file)
index 0000000..cdd4958
--- /dev/null
@@ -0,0 +1,10 @@
+--- lilypond-2.19.49.orig/lily/pango-font.cc   2016-10-16 07:16:18.000000000 -0400
++++ lilypond-2.19.49.new/lily/pango-font.cc    2016-10-29 22:39:02.921622080 -0400
+@@ -317,7 +317,7 @@
+   pango_fc_font_unlock_face (fcfont);
+   pango_glyph_string_free (pgs);
+   pgs = 0;
+-  PangoFontDescription *descr = pango_font_describe (pa->font);
++  PangoFontDescription *descr = pango_context_get_font_description (context_);
+   Real size = pango_font_description_get_size (descr)
+               / (Real (PANGO_SCALE));
diff --git a/media-sound/lilypond/lilypond-2.21.1.ebuild b/media-sound/lilypond/lilypond-2.21.1.ebuild
new file mode 100644 (file)
index 0000000..216a4d4
--- /dev/null
@@ -0,0 +1,144 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
+
+if [[ "${PV}" = "9999" ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.savannah.gnu.org/git/lilypond.git"
+else
+       MAIN_VER=$(ver_cut 1-2)
+       SRC_URI="http://lilypond.org/download/sources/v${MAIN_VER}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+IUSE="debug emacs guile2 profile vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+       >=dev-texlive/texlive-metapost-2013
+       || (
+               >=app-text/texlive-core-2013
+               >=dev-tex/metapost-1.803
+       )
+       >=sys-apps/texinfo-4.11
+       >=sys-devel/bison-2.0
+       sys-devel/flex
+       virtual/pkgconfig
+"
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+       >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
+       media-fonts/tex-gyre
+       media-libs/fontconfig
+       media-libs/freetype:2
+       >=x11-libs/pango-1.12.3
+       emacs? ( >=app-editors/emacs-23.1:* )
+       guile2? ( >=dev-scheme/guile-2:12 )
+       !guile2? (
+               >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
+               <dev-scheme/guile-2.0:12
+       )
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+       app-text/t1utils
+       dev-lang/perl
+       dev-libs/kpathsea
+       media-gfx/fontforge[png]
+       sys-devel/gettext"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-fix-font-size.patch
+)
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+       # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+       if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+               if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+                       einfo "Updating metapost symlink"
+                       eselect mpost update || die
+               fi
+       fi
+
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       if ! use vim-syntax ; then
+               sed -i 's/vim//' GNUmakefile.in || die
+       fi
+
+       # respect CFLAGS
+       sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+       # remove bundled texinfo file (fixes bug #448560)
+       rm tex/texinfo.tex || die
+
+       eautoreconf
+
+       xdg_environment_reset #586592
+}
+
+src_configure() {
+       # documentation generation currently not supported since it requires a newer
+       # version of texi2html than is currently in the tree
+
+       local myeconfargs=(
+               --with-texgyre-dir=/usr/share/fonts/tex-gyre
+               --disable-documentation
+               --disable-optimising
+               --disable-pipe
+               $(use_enable debug debugging)
+               $(use_enable profile profiling)
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use emacs ; then
+               elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+                       || die "elisp-compile failed"
+       fi
+}
+
+src_install() {
+       emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+       # remove elisp files since they are in the wrong directory
+       rm -r "${ED}"/usr/share/emacs || die
+
+       if use emacs ; then
+               elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+                       || die "elisp-install failed"
+               elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+       fi
+
+       python_fix_shebang "${ED}"
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}
index 545b867b93565f6bd7f739eca3492d7b913b1849..6d4c51473a1fc6c62f75869d3238658bb478fe81 100644 (file)
@@ -2,15 +2,16 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-
 PYTHON_COMPAT=( python3_{6,7,8} )
+
 inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
 
 if [[ "${PV}" = "9999" ]]; then
        inherit git-r3
        EGIT_REPO_URI="https://git.savannah.gnu.org/git/lilypond.git"
 else
-       SRC_URI="http://lilypond.org/download/sources/v$(ver_cut 1-2)/${P}.tar.gz"
+       MAIN_VER=$(ver_cut 1-2)
+       SRC_URI="http://lilypond.org/download/sources/v${MAIN_VER}/${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
 fi
 
@@ -19,41 +20,45 @@ HOMEPAGE="http://lilypond.org/"
 
 LICENSE="GPL-3 FDL-1.3"
 SLOT="0"
-IUSE="debug emacs profile vim-syntax"
+IUSE="debug emacs guile2 profile vim-syntax"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-RDEPEND="${PYTHON_DEPS}
-       >=app-text/ghostscript-gpl-8.15
-       >=dev-scheme/guile-2:12[deprecated,regex]
+BDEPEND="
+       >=dev-texlive/texlive-metapost-2013
+       || (
+               >=app-text/texlive-core-2013
+               >=dev-tex/metapost-1.803
+       )
+       >=sys-apps/texinfo-4.11
+       >=sys-devel/bison-2.0
+       sys-devel/flex
+       virtual/pkgconfig
+"
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+       >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
        media-fonts/tex-gyre
        media-libs/fontconfig
        media-libs/freetype:2
        >=x11-libs/pango-1.12.3
        emacs? ( >=app-editors/emacs-23.1:* )
-"
+       guile2? ( >=dev-scheme/guile-2:12 )
+       !guile2? (
+               >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
+               <dev-scheme/guile-2.0:12
+       )
+       ${PYTHON_DEPS}"
 DEPEND="${RDEPEND}
        app-text/t1utils
        dev-lang/perl
        dev-libs/kpathsea
-       >=dev-texlive/texlive-metapost-2013
-       || (
-               >=app-text/texlive-core-2013
-               >=dev-tex/metapost-1.803
-       )
-       virtual/pkgconfig
        media-gfx/fontforge[png]
-       >=sys-apps/texinfo-4.11
-       >=sys-devel/bison-2.0
-       sys-devel/flex
-       sys-devel/gettext
-       sys-devel/make
-"
+       sys-devel/gettext"
 
 # Correct output data for tests isn't bundled with releases
 RESTRICT="test"
 
 PATCHES=(
-       "${FILESDIR}"/${PN}-2.19.80-fontforge-version.patch
+       "${FILESDIR}"/${PN}-2.21.1-fix-font-size.patch
 )
 
 DOCS=( DEDICATION HACKING README.txt ROADMAP )
@@ -80,9 +85,6 @@ src_prepare() {
        # respect CFLAGS
        sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
 
-       # respect AR
-       sed -i "s:^AR=ar:AR=$(tc-getAR):" flower/GNUmakefile || die
-
        # remove bundled texinfo file (fixes bug #448560)
        rm tex/texinfo.tex || die