app-emulation/diskimage-builder: 2.18.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 5 Nov 2018 18:08:23 +0000 (12:08 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 5 Nov 2018 18:08:47 +0000 (12:08 -0600)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/diskimage-builder/Manifest
app-emulation/diskimage-builder/diskimage-builder-2.18.0.ebuild [new file with mode: 0644]

index 3929ecaf2506b8ca50daaeff7d2700d1f80604e5..58b767661a56eaa2ff7ad802c826b9325cb55bbb 100644 (file)
@@ -1,2 +1,3 @@
 DIST diskimage-builder-2.16.0.tar.gz 357777 BLAKE2B 29d9c2e0a2a42de3939a0ebac499f13755ef883074a43f7147e322af8c6cb2120fc0987271a4f6d4cead775283b4d502302dd50e8b3411e265c826b7f7fb9617 SHA512 2a10d7e3b69968f91de9f3aded7109addbe48201567257f1e849985dca7ad4860247aac431d3055780f2345670d10a27714acfb74507078bd6ec585c05cc7635
 DIST diskimage-builder-2.17.0.tar.gz 362965 BLAKE2B 27668c38e480aa14354a7efcb7f3f64b9cfe9f7a61507d2e08809a757aba95f3d51754b35985089c39bc3bca1204e9e2325e19e0d4f77996e22b479e6d804ae2 SHA512 02505823ba48da235127f9bd686bbad3dec32feb2252e5c5b69723a53f6d0926a384c6be5a4055bebf9e0ded82cd9945dab6f26fa7db280722f45d27fef25bc9
+DIST diskimage-builder-2.18.0.tar.gz 357151 BLAKE2B 0516a7028f3ad3d544f575ba61bf04a79d5227008471e6ce5637b762798d3947cb111312ddfd5ca73d39e6b7e01a98ff34925bb30857581e3c135f3da17a4ecd SHA512 64b329ba9494041cd432fa9ff42e15c4b409ed57edbb3c91b791ff2b0d0fce860c32d2d020c36c23c97d9cd100aa287abd98d5e537a02c38d81cd0f9a2578e02
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.18.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.18.0.ebuild
new file mode 100644 (file)
index 0000000..5a3f932
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+       <dev-python/networkx-2.0[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+       >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+       <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       app-emulation/qemu
+       sys-block/parted
+       sys-fs/multipath-tools
+       sys-fs/dosfstools
+       sys-apps/gptfdisk
+       !dev-python/dib-utils[${PYTHON_USEDEP}]"