net-p2p/bitcoin{-qt,d}-0.16.3: Drop bitcoin_policy_rbf USE flag
authorLuke Dashjr <luke-jr+git@utopios.org>
Mon, 30 Sep 2019 03:27:05 +0000 (03:27 +0000)
committerCraig Andrews <candrews@gentoo.org>
Sat, 7 Mar 2020 21:15:14 +0000 (16:15 -0500)
It is now always enabled at build time.
Users who don't like it can turn it off at runtime.

Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
net-p2p/bitcoin-qt/metadata.xml
net-p2p/bitcoind/bitcoind-0.16.3.ebuild
net-p2p/bitcoind/metadata.xml

index 0ee413a509bd7ca01b97cfd63362d8e01f0ac014..95339d5b90b1582d9857813e720a0cca0cf1f835 100644 (file)
@@ -21,7 +21,7 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 ~ppc x86 ~amd64-linux ~x86-linux"
 
-IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
+IUSE="+asm +bip70 dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -69,14 +69,9 @@ pkg_pretend() {
                elog "For more information, see:"
                elog "https://bitcoincore.org/en/2018/09/18/release-${PV}/"
        fi
-       if use bitcoin_policy_rbf; then
-               elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
-               elog "relay transactions paying the highest fee, regardless of receive order."
-       else
-               elog "Replace By Fee policy is disabled: Your node will only accept the first"
-               elog "transaction seen consuming a conflicting input, regardless of fee"
-               elog "offered by later ones."
-       fi
+       elog "Replace By Fee policy is now always enabled by default: Your node will"
+       elog "preferentially mine and relay transactions paying the highest fee, regardless"
+       elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
 }
 
 src_prepare() {
@@ -98,10 +93,6 @@ src_prepare() {
 
        eapply_user
 
-       if ! use bitcoin_policy_rbf; then
-               sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
-       fi
-
        echo '#!/bin/true' >share/genbuild.sh || die
        mkdir -p src/obj || die
        echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
index 0e5739a73259e925113d218597ff72dd894cf7f3..d37cf8037b83838445e798e8a0cc2352223c8420 100644 (file)
@@ -12,7 +12,6 @@
        <use>
                <flag name="asm">Enable assembly for optimization</flag>
                <flag name="bip70">Enable support for the BIP70 payment protocol</flag>
-               <flag name="bitcoin_policy_rbf">Replace By Fee policy: Your node will preferentially mine and relay transactions paying the highest fee, regardless of receive order</flag>
                <flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
                <flag name="libevent">Use dev-libs/libevent (needed for JSON-RPC, REST, and Tor auto-configuration</flag>
                <flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>
index 86589b99be5e15b9348251331bd3c809f24b9143..585ba9254842c703394f8f84d427275bdc9ede0f 100644 (file)
@@ -20,7 +20,7 @@ SRC_URI="
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="+asm +bitcoin_policy_rbf examples knots libressl test upnp +wallet zeromq"
+IUSE="+asm examples knots libressl test upnp +wallet zeromq"
 RESTRICT="!test? ( test )"
 
 DEPEND="
@@ -51,14 +51,9 @@ pkg_pretend() {
                elog "For more information, see:"
                elog "https://bitcoincore.org/en/2018/09/18/release-${PV}/"
        fi
-       if use bitcoin_policy_rbf; then
-               elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
-               elog "relay transactions paying the highest fee, regardless of receive order."
-       else
-               elog "Replace By Fee policy is disabled: Your node will only accept the first"
-               elog "transaction seen consuming a conflicting input, regardless of fee"
-               elog "offered by later ones."
-       fi
+       elog "Replace By Fee policy is now always enabled by default: Your node will"
+       elog "preferentially mine and relay transactions paying the highest fee, regardless"
+       elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
 }
 
 pkg_setup() {
@@ -82,10 +77,6 @@ src_prepare() {
 
        eapply_user
 
-       if ! use bitcoin_policy_rbf; then
-               sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
-       fi
-
        echo '#!/bin/true' >share/genbuild.sh || die
        mkdir -p src/obj || die
        echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
index 6283c9d733c0cea741665fafff418c63507daf62..31bb9103620b356e2efa5ea071af760e93317d74 100644 (file)
@@ -11,7 +11,6 @@
        </maintainer>
        <use>
                <flag name="asm">Enable assembly for optimization</flag>
-               <flag name="bitcoin_policy_rbf">Replace By Fee policy: Your node will preferentially mine and relay transactions paying the highest fee, regardless of receive order</flag>
                <flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
                <flag name="system-leveldb">Use the system-wide dev-libs/leveldb instead of bundled</flag>
                <flag name="upnp">Enable Universal Plug and Play</flag>