dev-python/www-authenticate: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 15:08:03 +0000 (17:08 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 15:16:21 +0000 (17:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/www-authenticate/www-authenticate-0.9.2.ebuild

index d56aaf333fe8f43f9090108185eb6ed6d344caf3..c315ec4d2864fb8b20068f56a1bc9678367be437 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
 DESCRIPTION="WWW-Authenticate header parser"
@@ -13,14 +13,5 @@ SRC_URI="https://github.com/alexsdutton/www-authenticate/archive/${PV}.tar.gz ->
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-RDEPEND=""
-DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
-       nosetests tests.py || die
-}
+distutils_enable_tests nose