dev-ruby/marcel: avoid bundler dependency
authorHans de Graaff <graaff@gentoo.org>
Sun, 24 May 2020 03:39:22 +0000 (05:39 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 24 May 2020 04:13:19 +0000 (06:13 +0200)
Closes: https://bugs.gentoo.org/723850
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/marcel/marcel-0.3.3-r1.ebuild

index 40fae2ec8e91d1411c31a7183a9081a9764652f8..27849fa36df599c5e39b530734c3a6689473c7f4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -25,6 +25,8 @@ ruby_add_rdepend ">=dev-ruby/mimemagic-0.3.2:0"
 all_ruby_prepare() {
        sed -i -e '2irequire "pathname"' test/test_helper.rb || die
 
+       sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
        # Account for changes in shared-mime-info 1.10
        mkdir test/fixtures/{magic,name}/font || die
        mv test/fixtures/magic/application/x-font-ttf.ttf test/fixtures/magic/font/ttf.ttf || die