version bump
authorAlexis Ballier <aballier@gentoo.org>
Tue, 10 Jan 2012 13:27:01 +0000 (13:27 +0000)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 10 Jan 2012 13:27:01 +0000 (13:27 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

dev-ml/camlp5/ChangeLog
dev-ml/camlp5/camlp5-6.03.ebuild [new file with mode: 0644]
dev-ml/camomile/ChangeLog
dev-ml/camomile/camomile-0.8.4.ebuild [new file with mode: 0644]

index 2cf2db3cad274bcddb480543645601591aff0225..29f4b78851673b93dc564b8e65db401987437fa0 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ml/camlp5
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.61 2011/12/18 17:33:47 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.62 2012/01/10 13:22:35 aballier Exp $
+
+*camlp5-6.03 (10 Jan 2012)
+
+  10 Jan 2012; Alexis Ballier <aballier@gentoo.org> +camlp5-6.03.ebuild:
+  version bump
 
   18 Dec 2011; Raúl Porcel <armin76@gentoo.org> camlp5-5.14.ebuild,
   camlp5-6.02.3.ebuild, camlp5-6.02.3_p1.ebuild:
diff --git a/dev-ml/camlp5/camlp5-6.03.ebuild b/dev-ml/camlp5/camlp5-6.03.ebuild
new file mode 100644 (file)
index 0000000..371801d
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.03.ebuild,v 1.1 2012/01/10 13:22:35 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+MY_P=${P%_p*}
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+PATCHLEVEL=${PV#*_p}
+PATCHLIST=""
+
+if [ "${PATCHLEVEL}" != "${PV}" ] ; then
+       for i in $(seq 1 ${PATCHLEVEL}) ; do
+               SRC_URI="${SRC_URI}
+                       http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
+               PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
+       done
+fi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       for i in ${PATCHLIST} ; do
+               epatch "${DISTDIR}/${i}"
+       done
+}
+
+src_configure() {
+       ./configure \
+               -prefix /usr \
+           -bindir /usr/bin \
+               -libdir /usr/$(get_libdir)/ocaml \
+               -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+       emake || die "emake failed"
+       if use ocamlopt; then
+               emake  opt || die "Compiling native code programs failed"
+               emake  opt.opt || die "Compiling native code programs failed"
+       fi
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       # findlib support
+       insinto "$(ocamlfind printconf destdir)/${PN}"
+       doins etc/META || die "failed to install META file for findlib support"
+
+       use doc && dohtml -r doc/*
+
+       dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}
index a648cbd60e612e53e84b5068094f3c626437fc3a..76d99189eb9871beb7aa62e88ab04dd1c6625814 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ml/camomile
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.29 2011/07/23 11:18:02 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.30 2012/01/10 13:27:01 aballier Exp $
+
+*camomile-0.8.4 (10 Jan 2012)
+
+  10 Jan 2012; Alexis Ballier <aballier@gentoo.org> +camomile-0.8.4.ebuild:
+  version bump
 
   23 Jul 2011; Markus Meier <maekke@gentoo.org> camomile-0.8.3.ebuild:
   x86 stable, bug #374965
diff --git a/dev-ml/camomile/camomile-0.8.4.ebuild b/dev-ml/camomile/camomile-0.8.4.ebuild
new file mode 100644 (file)
index 0000000..eb9ac2e
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.8.4.ebuild,v 1.1 2012/01/10 13:27:01 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
+HOMEPAGE="http://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="http://github.com/downloads/yoriyuki/Camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       econf $(use_enable debug)
+}
+
+src_compile() {
+       emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+       if use ocamlopt; then
+               emake -j1 opt || die "failed to build native code"
+       fi
+}
+
+src_install() {
+       dodir /usr/bin
+       findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}