games-puzzle/einstein: Drop old
authorPacho Ramos <pacho@gentoo.org>
Tue, 1 May 2018 11:06:16 +0000 (13:06 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 1 May 2018 19:32:19 +0000 (21:32 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-puzzle/einstein/Manifest
games-puzzle/einstein/einstein-2.0.ebuild [deleted file]
games-puzzle/einstein/files/einstein-2.0-64bit.patch [deleted file]
games-puzzle/einstein/files/einstein-2.0-gcc43.patch [deleted file]

index 41d7c0065b270c1860d28dd70dad3821c393d1b0..89d46b3acbcd0b1475622a2160c4caa662fe5a17 100644 (file)
@@ -1,3 +1,2 @@
-DIST einstein-2.0-src.tar.gz 722301 BLAKE2B 3cb857bbbbfe9d3dab763d461dfe0c91ed204ac2e080a6d546e35cb869da05a8735900bd1db071074628b11f77e675bc21a811a79079587c6388b58ba401dcd1 SHA512 45599546f2f7fce32f7441cfdae88b72297f4a506d9eb98a64c3b24ec2e2fd86a63d59961a21e017df6a7a676d864ad12598d735f9049adf43cddd91d661f619
 DIST einstein.png 932 BLAKE2B 13ecf24e5600bf39bbaec662afda5b4fdba2c5adf4560e8f08996b2e6c475002857187be2dac2d2c898cdb63854cc7ea1748b6b1d34a67adcc2f4789aafd5c25 SHA512 9e19d351e915509a11d7275ef0ea7e246d0d334933ec4b48ea0f56aa552ac69041a5c2a64075b02ec3601b1c2b8307cef314c9427ab7615b16e689faaa074283
 DIST v2.1.1.tar.gz 1317979 BLAKE2B 7924774c2d540ecd7cbecb344907d20ab9514219407a02852bbd80bbb9d1d27bac14654a1553dbe30e8f0fd79e08f12338a4e43dfc3c06bfb433fb3a46330a64 SHA512 e34e8e0ef47c311d7417c42ba306b9e9cf94d1fd1829b3948d791543d1fb5f8f1d8d975154bab2559691cf3b94574d5485f8541882d59dd0b6284ff76e435cf3
diff --git a/games-puzzle/einstein/einstein-2.0.ebuild b/games-puzzle/einstein/einstein-2.0.ebuild
deleted file mode 100644 (file)
index a689cf7..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="A puzzle game inspired by Albert Einstein"
-HOMEPAGE="https://freecode.com/projects/einsteinpuzzle"
-SRC_URI="mirror://gentoo/${P}-src.tar.gz
-       mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[sound,video]
-       media-libs/sdl-mixer
-       media-libs/sdl-ttf"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}*.patch
-       sed -i \
-               -e "/PREFIX/s:/usr/local:${GAMES_PREFIX}:" \
-               -e "s:\$(PREFIX)/share/einstein:${GAMES_DATADIR}/${PN}:" \
-               -e "s:\$(PREFIX)/bin:${GAMES_BINDIR}:" \
-               -e "s/\(OPTIMIZE=[^#]*\)/\0 ${CXXFLAGS}/" Makefile \
-               || die
-       sed -i \
-               -e "s:PREFIX L\"/share/einstein:L\"${GAMES_DATADIR}/${PN}:" main.cpp \
-               || die
-}
-
-src_install() {
-       dogamesbin "${PN}"
-       insinto "${GAMES_DATADIR}/${PN}/res"
-       doins einstein.res
-       doicon "${DISTDIR}"/${PN}.png
-       make_desktop_entry ${PN} "Einstein Puzzle"
-       prepgamesdirs
-}
diff --git a/games-puzzle/einstein/files/einstein-2.0-64bit.patch b/games-puzzle/einstein/files/einstein-2.0-64bit.patch
deleted file mode 100644 (file)
index 4d66562..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- einstein-2.0.orig/formatter.cpp
-+++ einstein-2.0/formatter.cpp
-@@ -58,7 +58,7 @@
-             if ((c.type == INT_ARG) || (c.type == STRING_ARG) ||
-                     (c.type == FLOAT_ARG) || (c.type == DOUBLE_ARG))
-             {
--                int no = (int)c.data;
-+                long int no = (long int)c.data;
-                 args[no - 1] = c.type;
-             }
-         }
-@@ -123,7 +123,7 @@
- std::wstring Formatter::format(std::vector<ArgValue*> &argValues) const
- {
-     std::wstring s;
--    int no;
-+    long int no;
-     for (int i = 0; i < commandsCnt; i++) {
-         Command *cmd = &commands[i];
-@@ -135,8 +135,8 @@
-                 
-             case STRING_ARG:
-             case INT_ARG:
--                no = (int)cmd->data - 1;
--                if (no < (int)argValues.size())
-+                no = (long int)cmd->data - 1;
-+                if (no < (long int)argValues.size())
-                     s += argValues[no]->format(cmd);
-                 break;
diff --git a/games-puzzle/einstein/files/einstein-2.0-gcc43.patch b/games-puzzle/einstein/files/einstein-2.0-gcc43.patch
deleted file mode 100644 (file)
index 25e1815..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- einstein-2.0.orig/convert.h
-+++ einstein-2.0/convert.h
-@@ -5,6 +5,7 @@
- #include <iostream>
- #include <sstream>
- #include <string>
-+#include <typeinfo>
- #include "exceptions.h"
- #include "unicode.h"
-
---- einstein-2.0.orig/unicode.cpp
-+++ einstein-2.0/unicode.cpp
-@@ -1,5 +1,6 @@
- #include <wchar.h>
- #include <stdlib.h>
-+#include <string.h>
- #ifdef WIN32
- #include <windows.h>
- #endif