Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Mon, 15 Jan 2007 20:09:22 +0000 (20:09 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Mon, 15 Jan 2007 20:09:22 +0000 (20:09 +0000)
Package-Manager: portage-2.1.2_rc4-r8

dev-ruby/mod_ruby/ChangeLog
dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild

index e724f6806636cfc85c635249e6ca884e8ce56c6e..0e4fd60667fdbe4972d1b78b3697ca0054c39520 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-ruby/mod_ruby
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/ChangeLog,v 1.23 2007/01/13 18:38:18 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/ChangeLog,v 1.24 2007/01/15 20:09:22 chtekk Exp $
+
+  15 Jan 2007; Luca Longinotti <chtekk@gentoo.org> -files/mod_ruby.conf,
+  mod_ruby-1.2.4-r2.ebuild:
+  Cleanup.
 
   13 Jan 2007; Luca Longinotti <chtekk@gentoo.org> -files/20_mod_ruby.conf,
   -mod_ruby-1.0.7.ebuild, -mod_ruby-1.2.2.ebuild, -mod_ruby-1.2.4.ebuild,
index b5cfbb5055f27d1bb7626174f147f84a93d4abc4..cc83e70e8ea7853d3bf8918881c3f87317ec6a88 100644 (file)
@@ -1,49 +1,49 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild,v 1.10 2006/10/20 19:18:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild,v 1.11 2007/01/15 20:09:22 chtekk Exp $
 
 inherit apache-module
 
-DESCRIPTION="Embeds the Ruby interpreter into Apache"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86"
+
+DESCRIPTION="Embeds the Ruby interpreter into Apache."
 HOMEPAGE="http://modruby.net/"
 SRC_URI="http://modruby.net/archive/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86"
 IUSE="doc"
 
-DEPEND="virtual/ruby
-       doc? ( dev-ruby/rdtool )"
 RDEPEND="virtual/ruby"
+DEPEND="${RDEPEND}
+               doc? ( dev-ruby/rdtool )"
 
-APACHE1_MOD_CONF="mod_ruby"
+APACHE1_MOD_CONF="21_mod_ruby"
 APACHE2_MOD_CONF="21_mod_ruby"
 APACHE1_MOD_DEFINE="RUBY"
 APACHE2_MOD_DEFINE="RUBY"
 APACHE1_MOD_FILE="${PN}.so"
 APACHE2_MOD_FILE="${PN}.so"
-DOCFILES="ChangeLog COPYING README.* doc/*.html doc/*.css"
+
+DOCFILES="ChangeLog COPYING README.*"
 
 need_apache
 
 src_compile() {
-       use apache2 || ./configure.rb --with-apxs=${APXS1}
        use apache2 && ./configure.rb --with-apxs=${APXS2}
+       use apache2 || ./configure.rb --with-apxs=${APXS1}
 
-       ./configure.rb --with-apxs=${APXS}
-
-       emake || die "make failed"
+       emake || die "emake failed"
 
-       if use doc; then
+       if use doc ; then
                cd doc
-               emake || die "make failed"
+               emake || die "emake doc failed"
        fi
 }
 
 src_install() {
-       emake DESTDIR=${D} install || die "make install failed"
+       emake DESTDIR="${D}" install || die "emake install failed"
 
-       if use doc; then
+       if use doc ; then
                dohtml doc/*.css doc/*.html
        fi