app-emulation/libvirt-6.0.0: And the agent job in qemuDomainSetTimeAgent
authorMichal Privoznik <mprivozn@redhat.com>
Sat, 4 Apr 2020 07:45:31 +0000 (09:45 +0200)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 5 Apr 2020 17:19:16 +0000 (12:19 -0500)
Cherry-pick of d61f95cf6a6fbd564e104c168d325581acd9cd8d from the
libvirt's upstream repo.

Closes: https://bugs.gentoo.org/715494

Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/libvirt/files/libvirt-6.0.0-qemu-end-the-agent-job-in-qemuDomainSetTimeAgent.patch [new file with mode: 0644]
app-emulation/libvirt/libvirt-6.0.0-r2.ebuild [moved from app-emulation/libvirt/libvirt-6.0.0-r1.ebuild with 99% similarity]

diff --git a/app-emulation/libvirt/files/libvirt-6.0.0-qemu-end-the-agent-job-in-qemuDomainSetTimeAgent.patch b/app-emulation/libvirt/files/libvirt-6.0.0-qemu-end-the-agent-job-in-qemuDomainSetTimeAgent.patch
new file mode 100644 (file)
index 0000000..62f89a3
--- /dev/null
@@ -0,0 +1,39 @@
+From ba756e8d0928ac4ddb7decd1033de2121201d941 Mon Sep 17 00:00:00 2001
+Message-Id: <ba756e8d0928ac4ddb7decd1033de2121201d941.1585986243.git.mprivozn@redhat.com>
+From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
+Date: Mon, 20 Jan 2020 07:55:48 +0100
+Subject: [PATCH] qemu: end the agent job in qemuDomainSetTimeAgent
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This function grabs an agent job but ends a monitor job.
+End the agent job instead.
+
+https://bugzilla.redhat.com/show_bug.cgi?id=1792723
+
+Signed-off-by: Ján Tomko <jtomko@redhat.com>
+Reported-by: Dan Zheng <dzheng@redhat.com>
+Fixes: e005c95f56fee9ed780be7f8db103d690bd34cbd
+(cherry picked from commit d61f95cf6a6fbd564e104c168d325581acd9cd8d)
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ src/qemu/qemu_driver.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c
+index d6b1e9f00c..48cd5b95d9 100644
+--- a/src/qemu/qemu_driver.c
++++ b/src/qemu/qemu_driver.c
+@@ -20376,7 +20376,7 @@ qemuDomainSetTimeAgent(virQEMUDriverPtr driver,
+     qemuDomainObjExitAgent(vm, agent);
+  endjob:
+-    qemuDomainObjEndJob(driver, vm);
++    qemuDomainObjEndAgentJob(vm);
+     return ret;
+ }
+-- 
+2.24.1
+
similarity index 99%
rename from app-emulation/libvirt/libvirt-6.0.0-r1.ebuild
rename to app-emulation/libvirt/libvirt-6.0.0-r2.ebuild
index d877620ac914c029777967e5d6d17bf0a91e28d4..80289b5c551efcbf51aba9dbe0c1907526238567 100644 (file)
@@ -128,6 +128,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-6.0.0-do-not-use-sysconf.patch
        "${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch
        "${FILESDIR}"/${PN}-5.2.0-fix-paths-for-apparmor.patch
+       "${FILESDIR}"/${PN}-6.0.0-qemu-end-the-agent-job-in-qemuDomainSetTimeAgent.patch
 )
 
 pkg_setup() {