dev-cpp/libmcpp: Bump to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 17:14:49 +0000 (18:14 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 17:15:09 +0000 (18:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch [new file with mode: 0644]
dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild [new file with mode: 0644]

diff --git a/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch b/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch
new file mode 100644 (file)
index 0000000..95cefad
--- /dev/null
@@ -0,0 +1,30 @@
+Specify and install files using idiomatic Automake
+conventions instead of manually installing with cp.
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -23,16 +23,12 @@
+   $(top_srcdir)/test-c $(top_srcdir)/test-l $(top_srcdir)/tool  \
+   $(top_srcdir)/doc $(top_srcdir)/doc-jp
+-if ! REPLACE_CPP 
+-install-exec-hook:
+-      $(top_srcdir)/config/install-sh -d "$(DESTDIR)$(prefix)/share/doc/mcpp"
+-      cp -pf $(top_srcdir)/LICENSE $(top_srcdir)/README $(top_srcdir)/NEWS \
+-            $(DESTDIR)$(prefix)/share/doc/mcpp
+-      cp -pf $(top_srcdir)/doc/mcpp-manual.html   \
+-            $(DESTDIR)$(prefix)/share/doc/mcpp
+-      cp -pf $(top_srcdir)/doc-jp/mcpp-manual.html   \
+-            $(DESTDIR)$(prefix)/share/doc/mcpp/mcpp-manual-jp.html
+-uninstall-hook:
+-      rm -rf $(DESTDIR)$(prefix)/share/doc/mcpp
+-endif
++dist_doc_DATA = README NEWS doc/mcpp-summary.pdf
++dist_html_DATA = \
++      doc/cpp-test.html \
++      doc/mcpp-manual.html \
++      doc/mcpp-porting.html
++
++htmljadir = $(htmldir)/doc-jp
++dist_htmlja_DATA = doc-jp/mcpp-manual.html
diff --git a/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild b/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
new file mode 100644 (file)
index 0000000..05ac244
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_P=${P/lib/}
+
+DESCRIPTION="A portable C++ preprocessor"
+HOMEPAGE="http://mcpp.sourceforge.net"
+SRC_URI="mirror://sourceforge/mcpp/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86 ~x86-linux ~x64-macos"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.7.2-fix-build-system.patch )
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --enable-mcpplib \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+
+       if ! use static-libs; then
+               find "${D}" -name '*.la' -delete || die
+       fi
+}