sci-electronics/klayout: Remove old
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 18 Mar 2018 14:59:12 +0000 (15:59 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 19 Mar 2018 00:54:36 +0000 (01:54 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

sci-electronics/klayout/Manifest
sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo [deleted file]
sci-electronics/klayout/files/klayout-0.24.9-c++11-no-throw-in-destuctor.patch [deleted file]
sci-electronics/klayout/klayout-0.24.10.ebuild [deleted file]

index 8a5e5634f5b8456ddad61ef3557ad874c260e07f..9a6ef10503a4208d283aaaca3396e502cac41da1 100644 (file)
@@ -1,2 +1 @@
-DIST klayout-0.24.10.tar.gz 11262007 BLAKE2B 85e8d325a56672e6ba328f5ebf793f3c977542ed857621e504983a77e7762d795bbde0f572fb0017328bdb5c11e453f0cd9decedf3629f8ff0f2a6a25daf28c2 SHA512 0043b91e2dae9321299c217697c93af27bc7d795209bdf95248eee3690b97728854f9f82cc95f77f05a2cfbcae6a716ae594fe2485e04ed0a3f5d950abc0a31b
 DIST klayout-0.25.tar.gz 16461165 BLAKE2B 321d5c03b49b922b051407767f72135d0ff7e3fb0fe5dd237e27ce6c42d2b847f0bc4d96ae551c51b6581c0d39eb71f7053c8814dcb7afdfd027a24af9d553fd SHA512 0c05b0786e7e1dbf8035cbb3888eff776c0b96a4fcf2ebbc3065fe43340ae020b6713c2e1d2e7ab5caaf64d7ec84bea9d691ba6c0aea88e93c957530d3d4d114
diff --git a/sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo b/sci-electronics/klayout/files/klayout-0.23.10-Makefile.conf.linux-gentoo
deleted file mode 100644 (file)
index d51b60a..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-
-# Configuration file for 
-# gcc, Linux, 64bit
-# release build
-
-# Compiler options
-
-# Compiler general
-INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE) 
-DEFS=-DQT_THREAD_SUPPORT -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII
-
-# C++
-CXXOPT_DEP=-MM -MG 
-CXXWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
-       -Wsign-promo -Wsynth -Wno-long-long -Wno-strict-aliasing
-CXXOPT=-c $(CXXFLAGS) -o
-CXXOPT_SO=-fPIC $(CXXOPT) 
-
-# C
-CCOPT_DEP=-MM -MG 
-CCWARN=
-CCOPT=-c $(CFLAGS) -o
-CCOPT_SO=-fPIC $(CCOPT) 
-
-# Linker
-LINK=$(CXX)
-LOPT=-Wl,-E ${LDFLAGS} -o
-LOPT_SO=-shared -fPIC $(LOPT) 
-
-LIBS=-L$(QTLIB) -lQtGui -lQtCore -lQtXml -lQtNetwork -lQtSql -lQtDesigner -lrt -lstdc++ -lcrypt -ldl -lz -lpthread
-
-.PHONY: install
-install:
-       mkdir -p $(INSTALL_BINDIR)
-       cp main/$(EXEC_NAME) $(INSTALL_BINDIR)
-       for bin in $(OTHER_BIN) ; \
-       do \
-         cp main/$$bin $(INSTALL_BINDIR) ; \
-       done
-       for plugin in $(PLUGINS) ; \
-       do \
-         cp $$plugin/*.so $(INSTALL_BINDIR) ; \
-       done
-       chmod 755 $(INSTALL_BINDIR) $(INSTALL_BINDIR)/*
-
diff --git a/sci-electronics/klayout/files/klayout-0.24.9-c++11-no-throw-in-destuctor.patch b/sci-electronics/klayout/files/klayout-0.24.9-c++11-no-throw-in-destuctor.patch
deleted file mode 100644 (file)
index 4cb6473..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Fixes "error: throw will always call terminate() [-Werror=terminate]". Gentoo bug 612978.
-
---- a/src/tlAssert.h.old
-+++ b/src/tlAssert.h
-@@ -27,6 +27,16 @@
- #include "config.h"
-+// For >=C++11, mark assertion_failed() with attribute [[noreturn]] and call std::terminate().
-+// Or else, throw int(0) to tell the compiler that the assertion will not return.
-+#if __cplusplus < 201103L
-+#define ATTRIB_ASSERT KLAYOUT_DLL
-+#define END_ASSERT throw int(0)
-+#else
-+#define ATTRIB_ASSERT [[noreturn]] KLAYOUT_DLL
-+#define END_ASSERT std::terminate()
-+#endif
-+ 
- namespace tl
- {
-@@ -34,10 +44,10 @@
-  *  @brief The corresponding assert macro
-  */
--KLAYOUT_DLL void assertion_failed (const char *filename, unsigned int line, const char *condition);
-+ATTRIB_ASSERT void assertion_failed (const char *filename, unsigned int line, const char *condition);
- //  the throw int(0) instruction will tell the compiler that the assertion will not return
--#define tl_assert(COND) if (!(COND)) { tl::assertion_failed (__FILE__, __LINE__, #COND); throw int(0); }
-+#define tl_assert(COND) if (!(COND)) { tl::assertion_failed (__FILE__, __LINE__, #COND); END_ASSERT; }
- } // namespace tl
diff --git a/sci-electronics/klayout/klayout-0.24.10.ebuild b/sci-electronics/klayout/klayout-0.24.10.ebuild
deleted file mode 100644 (file)
index f4dfd05..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22"
-# note: define maximally ONE implementation here
-
-RUBY_OPTIONAL=no
-inherit eutils multilib toolchain-funcs ruby-ng
-
-DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
-HOMEPAGE="http://www.klayout.de/"
-SRC_URI="http://www.klayout.org/downloads/source/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-RDEPEND="
-       dev-qt/designer:4
-       dev-qt/qtgui:4[qt3support]
-       sys-libs/zlib
-       $(ruby_implementations_depend)
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.24.9-c++11-no-throw-in-destuctor.patch
-)
-
-all_ruby_prepare() {
-       # now we generate the stub build configuration file for the home-brew build system
-       cp "${FILESDIR}/${PN}-0.23.10-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
-}
-
-each_ruby_configure() {
-       ./build.sh \
-               -dry-run \
-               -platform linux-gentoo \
-               -bin bin \
-               -ruby ${RUBY} \
-               -qtbin "/usr/$(get_libdir)/qt4/bin" \
-               -qtinc /usr/include/qt4 \
-               -qtlib "/usr/$(get_libdir)/qt4" || die "Configuration failed"
-}
-
-each_ruby_compile() {
-       cd build.linux-gentoo
-       tc-export CC CXX AR LD RANLIB
-       export AR="${AR} -r"
-       emake all
-}
-
-each_ruby_install() {
-       cd build.linux-gentoo
-       emake install
-
-       cd ..
-       dobin bin/klayout
-
-       insinto /usr/share/${PN}/testdata/gds
-       doins testdata/gds/*.gds
-       insinto /usr/share/${PN}/testdata/oasis
-       doins testdata/oasis/*.oas testdata/oasis/*.ot
-
-       insinto /usr/share/${PN}
-       doins -r testdata/ruby
-}