media-sound/clementine: fix compilation with gcc-7.1
authorAlexander Golubev <fatzer2@gmail.com>
Tue, 16 May 2017 03:30:31 +0000 (06:30 +0300)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 16 May 2017 19:52:57 +0000 (21:52 +0200)
Gentoo-Bug: 618214
Closes: https://github.com/gentoo/gentoo/pull/4640

media-sound/clementine/clementine-1.3.1-r6.ebuild
media-sound/clementine/files/clementine-1.3.1-add-missing-functional-includes.patch [new file with mode: 0644]

index 6dfba6c726c4c10761111dd44d4bb57f0299d4ff..6d4916f0f570c4d2ddac616389e5bdd69cef97cb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -95,6 +95,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-fix-desktop-file.patch
        "${FILESDIR}"/${P}-chromaprint14.patch #603662
        "${FILESDIR}"/${P}-libechonest_removal.patch
+       "${FILESDIR}"/${P}-add-missing-functional-includes.patch #618214
 )
 
 src_prepare() {
diff --git a/media-sound/clementine/files/clementine-1.3.1-add-missing-functional-includes.patch b/media-sound/clementine/files/clementine-1.3.1-add-missing-functional-includes.patch
new file mode 100644 (file)
index 0000000..e480212
--- /dev/null
@@ -0,0 +1,51 @@
+From 8a6cc8b5069265e1e92e22def985e22c5955e503 Mon Sep 17 00:00:00 2001
+From: Morris Hafner <mmha@users.noreply.github.com>
+Date: Mon, 13 Feb 2017 17:46:46 +0100
+Subject: [PATCH] Add missing <functional> includes (#5630)
+
+---
+ src/core/mergedproxymodel.cpp | 1 +
+ src/devices/giolister.cpp     | 1 +
+ src/library/groupbydialog.cpp | 2 ++
+ 3 files changed, 4 insertions(+)
+
+diff --git a/src/core/mergedproxymodel.cpp b/src/core/mergedproxymodel.cpp
+index 56217f6..8c210d3 100644
+--- a/src/core/mergedproxymodel.cpp
++++ b/src/core/mergedproxymodel.cpp
+@@ -23,6 +23,7 @@
+ #include <QStringList>
++#include <functional>
+ #include <limits>
+ // boost::multi_index still relies on these being in the global namespace.
+diff --git a/src/devices/giolister.cpp b/src/devices/giolister.cpp
+index aa3bddb..5f63ef2 100644
+--- a/src/devices/giolister.cpp
++++ b/src/devices/giolister.cpp
+@@ -17,6 +17,7 @@
+ #include "config.h"
++#include <functional>
+ #include <memory>
+ #include <QFile>
+diff --git a/src/library/groupbydialog.cpp b/src/library/groupbydialog.cpp
+index 5efdc9f..e5f711b 100644
+--- a/src/library/groupbydialog.cpp
++++ b/src/library/groupbydialog.cpp
+@@ -20,6 +20,8 @@
+ #include <QPushButton>
++#include <functional>
++
+ // boost::multi_index still relies on these being in the global namespace.
+ using std::placeholders::_1;
+ using std::placeholders::_2;
+-- 
+2.10.2
+