dev-ros/qt_gui_cpp: Bump to 0.3.16.
authorAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 11:59:03 +0000 (12:59 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 11:59:03 +0000 (12:59 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/qt_gui_cpp/Manifest
dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.16.ebuild [new file with mode: 0644]

index 1669fe597af20a5a369754101e6e97b2608ddb36..1cca61b4651ff374f1f49fb06bfcfb2ab3cffe86 100644 (file)
@@ -1 +1,2 @@
 DIST qt_gui_core-0.3.11.tar.gz 91640 BLAKE2B 49615e039ea7a2586679c6d6ffd9a583a16c2087b1c1090885ca83894aa98d44efc10c7bb622068ac49eb8c70eac98a5f495e3b417b3750171c31b433c53bfad SHA512 f83abd1d75ea6794fc25da79912a629bd13167bbe2815c9616a0e1a8993a4730053fc737cb864ba01ac869d9aec85269d2e1a19d963a50b8469e6d073e55db9a
+DIST qt_gui_core-0.3.16.tar.gz 94321 BLAKE2B 87d38cfaa1ed46cdc6a08aaacef71844aec48226b6242b153d37d804e24a67300a84d7730d02f9cfcff42ab520b023b928bee6db354deec70744deb8c3136170 SHA512 44aaf7d07bc4223b1185fdfcd10f01f0eab0b2a3511dcb9cd055c98696becd07d46ceb1e15c6c78994e1069211b8c475d3b0a95523151a27e54c3f91ecc203dc
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.16.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.16.ebuild
new file mode 100644 (file)
index 0000000..359593e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtwidgets:5
+       >=dev-ros/pluginlib-1.9.23
+               dev-libs/tinyxml2:=
+       >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+       dev-libs/tinyxml
+       >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+       dev-libs/boost:=
+       dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+PATCHES=(
+       "${FILESDIR}/libdir.patch"
+)