dev-python/itsdangerous: add python 3.7 support
authorVirgil Dupras <vdupras@gentoo.org>
Mon, 20 Aug 2018 22:15:39 +0000 (18:15 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 21 Aug 2018 02:09:55 +0000 (22:09 -0400)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild b/dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild
new file mode 100644 (file)
index 0000000..6152888
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="https://pythonhosted.org/itsdangerous/ https://pypi.org/project/itsdangerous/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required for running tests.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+       if python_is_python3; then
+               2to3 -f unicode -nw --no-diffs tests.py
+       fi
+       "${PYTHON}" tests.py || die "Tests failed under ${EPYTHON}"
+}