dev-python/setproctitle: 1.1.10-r1 for py37 support
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 04:41:43 +0000 (23:41 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:52 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
new file mode 100644 (file)
index 0000000..1de283c
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# pypy doesn't get started in test run. Still required by www-servers/gunicorn
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# Required for re-write of test suite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+       # Make a nice html file
+       rst2html.py README.rst > README.html
+       # The README.rst will be duplicated in src_install
+       rm README.rst || die
+}
+
+python_test() {
+       # The suite via the Makefile appears to not cater to pypy
+       [[ ${EPYTHON} =~ pypy ]] && return
+
+       # prepare embedded executable
+       emake \
+               CC="$(tc-getCC)" \
+               PYINC="$(python_get_CFLAGS)" \
+               PYLIB="$(python_get_LIBS)" \
+               check
+}