sys-block/open-isns: Bump to version 0.99
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 12:32:49 +0000 (14:32 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 12:54:33 +0000 (14:54 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-block/open-isns/Manifest
sys-block/open-isns/open-isns-0.99.ebuild [new file with mode: 0644]

index feeeb17c2a1962c9e93e7258d90f71017eb9e6ad..6914def7947f40f25621ef073cf1102e47436305 100644 (file)
@@ -1,2 +1,3 @@
 DIST open-isns-0.97.tar.gz 278317 BLAKE2B 7083b3ebef78a5afb35e8cc31e86674b407eb48224139745142238f559e95ceca8755e570031559bdf29ec691947693303e07b8f81b915a3b7f2396329bbd2b3 SHA512 78c934162d5a1d093bccd49449d4ef369b896d34309d76b4963d643a699640617c4fe064388c481c35b9be26e012f19713f3aad378af9ad88fa94c3d300e919d
 DIST open-isns-0.98.tar.gz 278410 BLAKE2B f90df85de4d5fd2abdcd267e3c873dff62fcac523ee280e21def057eca366bbba21c2b3bfbf5cc0798b8d0f3b0d5028ebb49000cccc850abdfb85142a7b66c34 SHA512 04263b9ace9d272f4e3776c4e1a034815475590d4b4864217a6200fcd5baea391cd788723db3c17fe0d764efc9769a70a3d2167b00e5998fb4bcb8d5fe2547ed
+DIST open-isns-0.99.tar.gz 282831 BLAKE2B 7140daf08fda894bcbed3e25b122909ad0ed86b4f3db2e42a23b97480dea554194d2a33a3ebdf4e2017a57c2023dd8589f2e2fcfa60470cc3a6a3fbfb0d0ccbc SHA512 90a2297535c5e939f83c761173ce5f5f88e68adc31e41e833b23d07b6dc6959572ae7184db0084b861918199a877b251ebae4b4a7456fdd8c93400dc8457adc9
diff --git a/sys-block/open-isns/open-isns-0.99.ebuild b/sys-block/open-isns/open-isns-0.99.ebuild
new file mode 100644 (file)
index 0000000..e9c2b89
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="iSNS server and client for Linux"
+HOMEPAGE="https://github.com/open-iscsi/open-isns"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl slp ssl static"
+
+DEPEND="
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.98-libressl-compatibility.patch" )
+
+src_configure() {
+       use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+       append-lfs-flags
+       local myeconfargs=(
+                $(use_with slp)
+               $(use_with ssl security)
+               $(use_enable !static shared)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+       emake DESTDIR="${D}" install_hdrs
+       emake DESTDIR="${D}" install_lib
+       keepdir /var/lib/${PN/open-}
+       if ! use static ; then
+               find "${ED}" -type f -name "*.a" -delete || die
+       fi
+}