app-shells/thefuck: Version bump
authorManuel Rüger <mrueg@gentoo.org>
Mon, 14 Mar 2016 21:03:23 +0000 (22:03 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Mon, 14 Mar 2016 21:03:23 +0000 (22:03 +0100)
Package-Manager: portage-2.2.28

app-shells/thefuck/Manifest
app-shells/thefuck/thefuck-3.6.ebuild [new file with mode: 0644]

index d29f5bfdea07a70dbce2e19beed9d14b6772b499..86bfa28d654e2a44e45773367b96e23d0ca630fd 100644 (file)
@@ -1 +1,2 @@
 DIST thefuck-3.5.tar.gz 782640 SHA256 eaa6b6466634ab4c87506a1404871af5bfd013043157b335165a63da3b14d90e SHA512 b1d5c542e25dc88ddceef98cd067f3bd48023c4ca5ee33ea61c76ad089ca85d0f440b212633ad99f9e7caa2ca56da8ba236c481cacfb50fd07dec44e896a0a71 WHIRLPOOL dd8e7bde96b45e61874f519db52550f82aa269a1e0df94271bb58bd6605e1165e1e6e8682c257ca8129ebff2955c0014b71a0191a360ad035d4de2e17fab4ba8
+DIST thefuck-3.6.tar.gz 782923 SHA256 a83e2e3ff65b36a7e0d3330e853610c0da9cd2ffd5a001d9e51ad6146c558674 SHA512 630825f2a635fa8039df2b71e3a3d1c95280f48b1277f31f010a8c4adf1cd08ddbd6cff1ffae19856f27585f36c473d3c70eb30ca8e5e4cf8b159705398793bf WHIRLPOOL 17fc409d6114fb89527251888c40e05731932f192dedaefd33cd18e64c2b46980ad8a1c14a6f3bca02cfa223cde61216e2051afc458cca195919e3da94d08d91
diff --git a/app-shells/thefuck/thefuck-3.6.ebuild b/app-shells/thefuck/thefuck-3.6.ebuild
new file mode 100644 (file)
index 0000000..15c70cf
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pathlib[${PYTHON_USEDEP}]
+       dev-python/psutil[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/decorator[${PYTHON_USEDEP}]
+       dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+       dev-python/pytest[${PYTHON_USEDEP}] )
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+       sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       py.test || die
+}