games-emulation/mupen64plus-ui-console: Replace broken sed with patch
authorDavid Seifert <soap@gentoo.org>
Sun, 15 Sep 2019 13:11:49 +0000 (15:11 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 15 Sep 2019 13:11:49 +0000 (15:11 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch [new file with mode: 0644]
games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.9.ebuild

diff --git a/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch b/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch
new file mode 100644 (file)
index 0000000..c14491e
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/projects/unix/Makefile
++++ b/projects/unix/Makefile
+@@ -94,7 +94,7 @@
+     ifeq ($(ARCH_DETECTED), 64BITS)
+       CFLAGS += -pipe -arch x86_64 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
+     else
+-      CFLAGS += -pipe -mmmx -msse -fomit-frame-pointer -arch i686 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
++      CFLAGS += -pipe -arch i686 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
+     endif
+   endif
+ endif
+@@ -172,20 +172,6 @@
+ COMPILE.c = $(Q_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c
+ LINK.o = $(Q_LD)$(CC) $(CFLAGS) $(LDFLAGS) $(TARGET_ARCH)
+-ifeq ($(PIE), 1)
+-  CFLAGS += -fPIE
+-  LDFLAGS += -pie
+-else
+-  CFLAGS += -fno-PIE
+-  ifeq ($(CC),$(CROSS_COMPILE)gcc)
+-    # check if PIE is the default for the compiler
+-    PIE_DEFAULT = $(shell $(CC) -v 2>&1 | grep enable-default-pie)
+-    ifneq ($(PIE_DEFAULT),)
+-      LDFLAGS += -no-pie
+-    endif
+-  endif
+-endif
+-
+ # set installation options
+ ifeq ($(PREFIX),)
+   PREFIX := /usr/local
index 1741ecc220ca6626e88e6fe33bfb8768711fda8e..ec20f855224b28408d74a862ecc2a203a09f7152 100644 (file)
@@ -15,23 +15,20 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0=
+RDEPEND="
+       >=games-emulation/mupen64plus-core-${PV}:0=
        media-libs/libsdl2:0=
        !<games-emulation/mupen64plus-2.0"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
 S=${WORKDIR}/${MY_P}
 
-src_prepare() {
-       default
-
-       # avoid implicitly appending CPU flags
-       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
-
-       # avoid appending -fPIE/-fno-PIE
-       sed -i -e '/^if.*PIE/,/endif/d' projects/unix/Makefile || die
-}
+PATCHES=(
+       # 1. avoid implicitly appending CPU flags
+       # 2. avoid appending -fPIE/-fno-PIE
+       "${FILESDIR}"/${PN}-2.5.9-fix-makefile.patch
+)
 
 src_compile() {
        MAKEARGS=(