x11-terms/lilyterm: Fix .mo naming by Oleg (bug #562360).
authorJeroen Roovers <jer@gentoo.org>
Tue, 6 Oct 2015 05:31:05 +0000 (07:31 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 6 Oct 2015 05:31:05 +0000 (07:31 +0200)
Package-Manager: portage-2.2.22

x11-terms/lilyterm/files/lilyterm-0.9.9.4-gettext.patch [new file with mode: 0644]
x11-terms/lilyterm/lilyterm-0.9.9.4-r1.ebuild [new file with mode: 0644]

diff --git a/x11-terms/lilyterm/files/lilyterm-0.9.9.4-gettext.patch b/x11-terms/lilyterm/files/lilyterm-0.9.9.4-gettext.patch
new file mode 100644 (file)
index 0000000..c6df78d
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -51,7 +51,7 @@
+ AC_PROG_INTLTOOL
+ ALL_LINGUAS="$_LANG_LIST"
+-GETTEXT_PACKAGE="$_PACKAGE"
++GETTEXT_PACKAGE="$_BINARY"
+ AC_SUBST(GETTEXT_PACKAGE)
+ AM_GLIB_GNU_GETTEXT
+ AM_GLIB_DEFINE_LOCALEDIR(LOCALEDIR)
+
diff --git a/x11-terms/lilyterm/lilyterm-0.9.9.4-r1.ebuild b/x11-terms/lilyterm/lilyterm-0.9.9.4-r1.ebuild
new file mode 100644 (file)
index 0000000..f024b95
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="a terminal emulator based off of libvte that aims to be fast and lightweight"
+HOMEPAGE="http://lilyterm.luna.com.tw"
+LICENSE="GPL-3"
+SRC_URI="http://${PN}.luna.com.tw/file/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       x11-libs/vte:0
+"
+DEPEND="
+       ${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-0.9.9.4-gettext.patch
+
+       ./autogen.sh
+}