sys-libs/libomp: Branch for 5.0.0 release
authorMichał Górny <mgorny@gentoo.org>
Sun, 23 Jul 2017 16:51:28 +0000 (18:51 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 24 Jul 2017 19:03:50 +0000 (21:03 +0200)
sys-libs/libomp/libomp-5.0.9999.ebuild [new file with mode: 0644]

diff --git a/sys-libs/libomp/libomp-5.0.9999.ebuild b/sys-libs/libomp/libomp-5.0.9999.ebuild
new file mode 100644 (file)
index 0000000..086e4db
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-multilib git-r3 python-any-r1
+
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="https://openmp.llvm.org"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/openmp.git
+       https://github.com/llvm-mirror/openmp.git"
+EGIT_BRANCH="release_50"
+
+# Additional licenses:
+# - MIT-licensed Intel code,
+# - LLVM Software Grant from Intel.
+
+LICENSE="|| ( UoI-NCSA MIT ) MIT LLVM-Grant"
+SLOT="0"
+KEYWORDS=""
+IUSE="hwloc ompt test"
+
+RDEPEND="hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )"
+# tests:
+# - dev-python/lit provides the test runner
+# - sys-devel/llvm provide test utils (e.g. FileCheck)
+# - sys-devel/clang provides the compiler to run tests
+DEPEND="${RDEPEND}
+       dev-lang/perl
+       test? (
+               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
+               sys-devel/llvm
+               >=sys-devel/clang-3.9.0
+       )"
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+python_check_deps() {
+       has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+       use test && python-any-r1_pkg_setup
+}
+
+multilib_src_configure() {
+       local libdir="$(get_libdir)"
+       local mycmakeargs=(
+               -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+               -DLIBOMPTARGET_LIBDIR_SUFFIX="${libdir#lib}"
+               -DLIBOMP_USE_HWLOC=$(usex hwloc)
+               -DLIBOMP_OMPT_SUPPORT=$(usex ompt)
+               # do not install libgomp.so & libiomp5.so aliases
+               -DLIBOMP_INSTALL_ALIASES=OFF
+               # disable unnecessary hack copying stuff back to srcdir
+               -DLIBOMP_COPY_EXPORTS=OFF
+               -DLIBOMP_TEST_COMPILER="$(type -P "${CHOST}-clang")"
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_test() {
+       # respect TMPDIR!
+       local -x LIT_PRESERVES_TMP=1
+
+       cmake-utils_src_make check-libomp
+}