x11-misc/xsri: EAPI=7
authorJeroen Roovers <jer@gentoo.org>
Mon, 28 Oct 2019 09:14:00 +0000 (10:14 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 28 Oct 2019 09:14:43 +0000 (10:14 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/xsri/files/xsri-2.1.0-configure.patch
x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild [new file with mode: 0644]

index c000e7091092078b85baf7166e03a35c3fd07cf2..d7a92f9c9fb22d477d5681e6a7053518e73ffa0a 100644 (file)
@@ -16,7 +16,7 @@
  dnl library checks (not using macros/ directory)
  
 -PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 1.3.13,,
-+PKG_CHECK_MODULES(GTK, x11  gtk+-2.0 >= 1.3.13,,
++PKG_CHECK_MODULES(GTK, x11 gtk+-2.0 >= 1.3.13 gdk-pixbuf-2.0,,
      AC_MSG_ERROR([*** GTK+-2.0 must be installed to compile xsri]))
  
 +AC_CHECK_LIB(m, sqrt)
diff --git a/x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild b/x11-misc/xsri/xsri-2.1.0_p17_p12.ebuild
new file mode 100644 (file)
index 0000000..c72349d
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils rpm
+
+DESCRIPTION="The xsri wallpaper setter from RedHat"
+HOMEPAGE="https://fedoraproject.org"
+SRC_URI="
+       https://download.fedoraproject.org/pub/fedora/linux/releases/$(ver_cut 7)/Everything/source/SRPMS/${P/_p*/}-$(ver_cut 5).fc$(ver_cut 7).src.rpm
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+       dev-libs/glib:2
+       x11-libs/gdk-pixbuf
+       x11-libs/gtk+:2
+"
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+"
+PATCHES=(
+       "${FILESDIR}"/${P/_p*/}-configure.patch
+)
+S=${WORKDIR}/${P/_p*/}
+DOCS=( AUTHORS ChangeLog README )
+
+src_unpack() {
+       rpm_unpack
+       unpack "${WORKDIR}"/${P/_p*/}.tar.gz
+}
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_install() {
+       default
+       doman ../${PN}.1
+}