Version bump; bug #157697; thanks to Wojciech Myrda for the ebuild.
authorLars Weiler <pylon@gentoo.org>
Sun, 4 Feb 2007 02:35:24 +0000 (02:35 +0000)
committerLars Weiler <pylon@gentoo.org>
Sun, 4 Feb 2007 02:35:24 +0000 (02:35 +0000)
Package-Manager: portage-2.1.2-r5

app-cdr/isomaster/ChangeLog
app-cdr/isomaster/files/digest-isomaster-0.7 [new file with mode: 0644]
app-cdr/isomaster/isomaster-0.7.ebuild [new file with mode: 0644]

index 8fc47cbd772b723edfd060ba1a37e46d420eeb4c..f286aa6ac7901a8a444d2971a8bf748b49617daf 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-cdr/isomaster
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/ChangeLog,v 1.1 2006/12/03 05:55:55 pylon Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/ChangeLog,v 1.2 2007/02/04 02:35:24 pylon Exp $
+
+*isomaster-0.7 (04 Feb 2007)
+
+  04 Feb 2007; Lars Weiler <pylon@gentoo.org> +isomaster-0.7.ebuild:
+  Version bump; bug #157697; thanks to Wojciech Myrda for the ebuild.
 
 *isomaster-0.5 (03 Dec 2006)
 
diff --git a/app-cdr/isomaster/files/digest-isomaster-0.7 b/app-cdr/isomaster/files/digest-isomaster-0.7
new file mode 100644 (file)
index 0000000..b12be6e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ecc0a033211bb61c18a0bdde5612f2c9 isomaster-0.7.tar.bz2 161558
+RMD160 693f19986a96b73de265655e0bb1743192239746 isomaster-0.7.tar.bz2 161558
+SHA256 f72472173be1c69ce74249a956fe7cad80ce0563a97dd0cbc1fa098a24c851d7 isomaster-0.7.tar.bz2 161558
diff --git a/app-cdr/isomaster/isomaster-0.7.ebuild b/app-cdr/isomaster/isomaster-0.7.ebuild
new file mode 100644 (file)
index 0000000..17d45d2
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+DESCRIPTION="GTK2 (bootable) CD ISO Image editor."
+HOMEPAGE="http://littlesvr.ca/isomaster/"
+SRC_URI="http://littlesvr.ca/isomaster/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+       # make flags useful
+       sed -i -e "s:-Wall:${CFLAGS}:" Makefile || die "sed failed"
+       sed -i -e "s:-Wall:${CFLAGS}:" */Makefile || die "sed failed"
+
+       emake -j1 || die "emake failed"
+}
+
+src_install() {
+       emake PREFIX="/usr" DESTDIR="${D}" install || die "Install failed"
+       dodoc *.TXT bk/TODO.TXT
+
+       doicon icons/${PN}.png
+       make_desktop_entry ${PN} "Isomaster" ${PN}.png "Application;AudioVideo;"
+}
+