dev-libs/boost: Include patch for net-analyzer/icinga2
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 13:06:01 +0000 (14:06 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 13:06:01 +0000 (14:06 +0100)
Closes: https://bugs.gentoo.org/704128
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/boost/boost-1.72.0.ebuild
dev-libs/boost/files/boost-1.72.0-revert-cease-dependence-on-range.patch [new file with mode: 0644]

index 3417b408e432eea190fd09ccfa7fa6919aaf0a43..b44e04ef83defac1cb69b32cec91fc1793e3aece 100644 (file)
@@ -58,6 +58,8 @@ PATCHES=(
        "${FILESDIR}"/${PN}-1.72.0-missing-serialization-split_member-include.patch
        # Bug 703036, per python-impl Boost.MPI
        "${FILESDIR}"/${PN}-1.72.0-boost-mpi-python.patch
+       # Bug 704128, missing include on Boost.Ranges
+       "${FILESDIR}"/${PN}-1.72.0-revert-cease-dependence-on-range.patch
 )
 
 python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.72.0-revert-cease-dependence-on-range.patch b/dev-libs/boost/files/boost-1.72.0-revert-cease-dependence-on-range.patch
new file mode 100644 (file)
index 0000000..a600207
--- /dev/null
@@ -0,0 +1,49 @@
+From 436e1dbe6fcd31523d261d18ad011392f1d6fbbc Mon Sep 17 00:00:00 2001
+From: Oliver Kowalke <oliver.kowalke@gmail.com>
+Date: Sun, 1 Dec 2019 20:40:28 +0100
+Subject: [PATCH] Revert "Cease dependence on Range"
+
+This reverts commit 0c556bb59241e682bbcd3f572815149c5a9b17db.
+
+see #44 (One test fails to compile after boostorg/coroutine submodule updated)
+---
+ boost/coroutine/asymmetric_coroutine.hpp | 12 +++---------
+ 1 file changed, 3 insertions(+), 9 deletions(-)
+
+diff --git a/boost/coroutine/asymmetric_coroutine.hpp b/boost/coroutine/asymmetric_coroutine.hpp
+index ea96981..640896f 100644
+--- a/boost/coroutine/asymmetric_coroutine.hpp
++++ b/boost/coroutine/asymmetric_coroutine.hpp
+@@ -14,6 +14,7 @@
+ #include <boost/assert.hpp>
+ #include <boost/config.hpp>
+ #include <boost/move/move.hpp>
++#include <boost/range.hpp>
+ #include <boost/throw_exception.hpp>
+ #include <boost/utility/explicit_operator_bool.hpp>
+@@ -2354,19 +2355,12 @@ end( push_coroutine< R > & c)
+ }
+-// forward declaration of Boost.Range traits to break dependency on it
+-template<typename C, typename Enabler>
+-struct range_mutable_iterator;
+-
+-template<typename C, typename Enabler>
+-struct range_const_iterator;
+-
+ template< typename Arg >
+-struct range_mutable_iterator< coroutines::push_coroutine< Arg >, void >
++struct range_mutable_iterator< coroutines::push_coroutine< Arg > >
+ { typedef typename coroutines::push_coroutine< Arg >::iterator type; };
+ template< typename R >
+-struct range_mutable_iterator< coroutines::pull_coroutine< R >, void >
++struct range_mutable_iterator< coroutines::pull_coroutine< R > >
+ { typedef typename coroutines::pull_coroutine< R >::iterator type; };
+ }
+-- 
+2.24.1
+