app-emulation/reg: Version bump to 0.13.1
authorManuel Rüger <mrueg@gentoo.org>
Wed, 6 Jun 2018 20:24:44 +0000 (22:24 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Wed, 6 Jun 2018 20:24:44 +0000 (22:24 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-emulation/reg/Manifest
app-emulation/reg/reg-0.13.1.ebuild [new file with mode: 0644]

index 170f7bd31bd1f6889d5570b7b1bd8322d234e20d..72a6bf3e63c2684a6a334c7c24088d91076e35f8 100644 (file)
@@ -1 +1,2 @@
 DIST reg-0.13.0.tar.gz 14958008 BLAKE2B 7afdb3f00732ad3fe4e8581d0773ba3d8ed4e9d41704e5aec7e45f16e407d19cc30cf8d4461d32719200b0253d26b609ff641c760b220685edb98bfb49f9b6b6 SHA512 7b9c23de23b798e9da4902a00d965c62452997240f53980eda478c8fa59ade985ca2f25fbe902597bcb32440dfcd41bd72c4631b4f4be956a48b75875e134018
+DIST reg-0.13.1.tar.gz 2931156 BLAKE2B 56245364c348f800e77b25d4c7326a721bd041ac865aa4ac55eefa60a6d1746176e109247967f42bc48727c56fd91c47f2d76aa245f208aff64a26b77b4394f8 SHA512 c64b5a21cb5f2e3d64d9a80309a2eab3e1002b6aba1a59b87d873326e9c2c722ccbfa0778aa14a2cc1fca86dcd3ad1bf7eeef3e7293c835fef00e11e413decfb
diff --git a/app-emulation/reg/reg-0.13.1.ebuild b/app-emulation/reg/reg-0.13.1.ebuild
new file mode 100644 (file)
index 0000000..aa8ebef
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/reg"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="fc4797acd474fe66e617f491ced48c83f7aa355e"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+       pushd src/${EGO_PN} || die
+       GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+       popd || die
+}
+
+src_install() {
+       dobin bin/*
+       dodoc src/${EGO_PN}/README.md
+}