dev-ros/ament_cmake_gtest: Declare python_check_deps().
authorAlexis Ballier <aballier@gentoo.org>
Mon, 16 Dec 2019 11:34:18 +0000 (12:34 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 16 Dec 2019 13:49:43 +0000 (14:49 +0100)
Closes: https://bugs.gentoo.org/702726
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_gtest/ament_cmake_gtest-0.8.1.ebuild
dev-ros/ament_cmake_gtest/ament_cmake_gtest-9999.ebuild

index 0987702da7769e3b74f69296f3194419e4b0e34b..55a2af94568481eeddff0983a1a687d41fe92434 100644 (file)
@@ -39,3 +39,8 @@ BDEPEND="
        $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
+
+python_check_deps() {
+       has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+               has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}
index 0987702da7769e3b74f69296f3194419e4b0e34b..55a2af94568481eeddff0983a1a687d41fe92434 100644 (file)
@@ -39,3 +39,8 @@ BDEPEND="
        $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
+
+python_check_deps() {
+       has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+               has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}