media-libs/x265: delete all static libraries
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 23 May 2020 23:20:05 +0000 (01:20 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 24 May 2020 20:23:46 +0000 (22:23 +0200)
Closes: https://bugs.gentoo.org/724598
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
media-libs/x265/x265-3.3.ebuild

index ca3553d0293adca51fcaf747dfc4dd45dd560141..422b036bbd1d2ba56b572743afdbf8f12bc04ac4 100644 (file)
@@ -193,4 +193,9 @@ multilib_src_install() {
 
 multilib_src_install_all() {
        dodoc -r "${S}/../doc/"*
+
+       # we don't install *.a files for all variants,
+       # so just delete these files instead of pretending
+       # real USE=static-libs support
+       find "${ED}" -name "*.a" -delete || die
 }