Init script no longer requires bash.
authorRoy Marples <uberlord@gentoo.org>
Tue, 13 Mar 2007 07:37:41 +0000 (07:37 +0000)
committerRoy Marples <uberlord@gentoo.org>
Tue, 13 Mar 2007 07:37:41 +0000 (07:37 +0000)
Package-Manager: portage-2.1.2.2

sys-apps/hdparm/ChangeLog
sys-apps/hdparm/files/digest-hdparm-6.9-r1 [new file with mode: 0644]
sys-apps/hdparm/files/hdparm-init-8 [new file with mode: 0644]
sys-apps/hdparm/hdparm-6.9-r1.ebuild [new file with mode: 0644]

index 66c73c4a7352195dcb5d4cbe4529cc5f8ee9c374..edb3d624afc2320d07bc51af1e7a32b504102cfb 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/hdparm
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/ChangeLog,v 1.96 2007/03/12 18:25:05 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/ChangeLog,v 1.97 2007/03/13 07:37:41 uberlord Exp $
+
+*hdparm-6.9-r1 (13 Mar 2007)
+
+  13 Mar 2007; Roy Marples <uberlord@gentoo.org> +files/hdparm-init-8,
+  +hdparm-6.9-r1.ebuild:
+  Init script no longer requires bash.
 
   12 Mar 2007; Bryan Ã˜stergaard <kloeri@gentoo.org> hdparm-6.9.ebuild:
   Stable on Alpha, bug 170122.
diff --git a/sys-apps/hdparm/files/digest-hdparm-6.9-r1 b/sys-apps/hdparm/files/digest-hdparm-6.9-r1
new file mode 100644 (file)
index 0000000..f51e929
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 62749c6cdf28ce31aae335092fa107df hdparm-6.9.tar.gz 46801
+RMD160 d862e656456f14fb8139c15cd68ba9252082532e hdparm-6.9.tar.gz 46801
+SHA256 cae6ed86296d01be98ee3be0c224c4323eee508941a7f162a0366d56655afe06 hdparm-6.9.tar.gz 46801
diff --git a/sys-apps/hdparm/files/hdparm-init-8 b/sys-apps/hdparm/files/hdparm-init-8
new file mode 100644 (file)
index 0000000..3d712b2
--- /dev/null
@@ -0,0 +1,142 @@
+#!/sbin/runscript
+# METHOD
+# ------
+# if /dev/ide exists, find all block devices beneath it named disc, cd, or
+# generic.
+#
+# for the disc and cd ones, if there is a a matching /dev/hdX symlink and
+# hdX_args is set in the config file, use hdX_args.  otherwise, if there is a
+# matching /dev/discs/discX or /dev/cdroms/cdromX symlink, and discX_args or
+# cdromX_args is set in the config file, use discX_args / cdromX_args.  finally,
+# if all_args is set in the config file, use that.
+#
+# for the generic ones, sort them and look for genericX_args in the config file
+# or use all_args.
+#
+# if /dev/ide does not exist, check the /dev/hdX entries, and see which ones
+# correspond to real devices by opening them for reading.  then check hdX_args
+# and all_args in the config file.
+#
+# for each device considered, if no args are found in the config file, do not
+# run hdparm.
+
+depend() {
+       before bootmisc
+}
+
+do_hdparm() {
+       local e=
+       eval e=\$${extra_args}
+       [ -z "${args}${all_args}${e}" ] && return 0
+       
+       if [ -n "${args:=${all_args} ${e}}" ] ; then
+               local orgdevice="$(readlink -f "${device}")"
+               if [ -b "${orgdevice}" ] ; then
+                       ebegin "Running hdparm on ${device}"
+                       hdparm ${args} "${device}" > /dev/null
+                       eend $?
+               fi
+       fi
+}
+
+scan_devfs() {
+       local extra_args="pata_all_args" device= alias= args=
+
+       # devfs compatible systems
+       for device in $(find /dev/ide -name disc) ; do
+               args=''
+
+               for alias in /dev/hd? ; do
+                       if [ "${alias}" -ef "${device}" ] ; then
+                               device=${alias}
+                               eval args=\$"$(basename "${alias}")"_args
+                               break
+                       fi
+               done
+
+               if [ -z "$args" ] ; then
+                       for alias in /dev/discs/* ; do
+                               if [ "${alias}"/disc -ef "${device}" ]; then
+                                       device="${alias}/disc"
+                                       eval args=\$"$(basename "${alias}")"_args
+                                       break
+                               fi
+                       done
+               fi
+
+               do_hdparm
+       done
+
+       for device in $(find /dev/ide -name cd) ; do
+               args=''
+
+               for alias in /dev/hd? ; do
+                       if [ "${alias}" -ef "${device}" ] ; then
+                               device=${alias}
+                               eval args=\$"$(basename "${alias}")"_args
+                               break
+                       fi
+               done
+
+               if [ -z "$args" ] ; then
+                       for alias in /dev/cdroms/* ; do
+                               if [ "${alias}" -ef "${device}" ] ; then
+                                       device=${alias}
+                                       eval args=\$"$(basename "${alias}")"_args
+                                       break
+                               fi
+                       done
+               fi
+
+               do_hdparm
+       done
+
+       local count=0
+       # of course, the sort approach would fail here if any of the
+       # host/bus/target/lun numbers reached 2 digits..
+       for device in $(find /dev/ide -name generic | sort) ; do
+               eval args=\$generic${count}_args
+               do_hdparm
+               count=$((${count} + 1))
+       done
+}
+
+scan_nondevfs() {
+       # non-devfs compatible system
+       for device in /dev/hd* /dev/sd* ; do
+               [ -e "${device}" ] || continue
+               case "${device}" in
+                       *[0-9]) continue ;;
+                       /dev/hd*)  extra_args="pata_all_args" ;;
+                       /dev/sd*)  extra_args="sata_all_args" ;;
+                       *)         extra_args="" ;;
+               esac
+
+               # check that the block device really exists by
+               # opening it for reading
+               local errmsg= status= nomed=1
+               errmsg="$(export LC_ALL=C ; : 2>&1 <"${device}")"
+               status=$?
+               case "${errmsg}" in
+                   *": No medium found") nomed=0;;
+               esac
+               if [ -b "${device}" ] && [ "${status}" = "0" -o "${nomed}" = "0" ] ; then
+                       local conf_var="${device##*/}_args"
+                       eval args=\$${conf_var}
+                       do_hdparm
+               fi
+       done
+}
+
+start() {
+       if get_bootparam "nohdparm" ; then
+               ewarn "Skipping hdparm init as requested in kernel cmdline"
+               return 0
+       fi
+
+       if [ -e /dev/.devfsd -a -d /dev/ide ] ; then
+               scan_devfs
+       else
+               scan_nondevfs
+       fi
+}
diff --git a/sys-apps/hdparm/hdparm-6.9-r1.ebuild b/sys-apps/hdparm/hdparm-6.9-r1.ebuild
new file mode 100644 (file)
index 0000000..b97e0a6
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/hdparm-6.9-r1.ebuild,v 1.1 2007/03/13 07:37:41 uberlord Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to change hard drive performance parameters"
+HOMEPAGE="http://sourceforge.net/projects/hdparm/"
+SRC_URI="mirror://sourceforge/hdparm/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       sed -i \
+               -e "/^CFLAGS/ s:-O2:${CFLAGS}:" \
+               -e "/^LDFLAGS/ s:-s:${LDFLAGS}:" \
+               Makefile || die "sed"
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" || die "compile error"
+}
+
+src_install() {
+       into /
+       dosbin hdparm contrib/idectl || die "dosbin"
+
+       newinitd "${FILESDIR}"/hdparm-init-8 hdparm
+       newconfd "${FILESDIR}"/hdparm-conf.d.3 hdparm
+
+       doman hdparm.8
+       dodoc hdparm.lsm Changelog README.acoustic hdparm-sysconfig
+}