games-fps/quake1-data: EAPI=5
authorMichael Sterrett <mr_bones_@gentoo.org>
Tue, 12 Jan 2016 07:45:14 +0000 (02:45 -0500)
committerMichael Sterrett <mr_bones_@gentoo.org>
Tue, 12 Jan 2016 07:47:40 +0000 (02:47 -0500)
Package-Manager: portage-2.2.26

games-fps/quake1-data/quake1-data-2.40.ebuild

index 1e7eff5d247b720f7fa0f910beb61901d60b5f36..03074c5b58146cd16b0c6cea04bc139309fbc24c 100644 (file)
@@ -7,7 +7,7 @@
 # http://linux.omnipotent.net/article.php?article_id=11287
 # ftp://ftp.cdrom.com/pub/idgames/idstuff/quake/quake106.zip
 
-EAPI=2
+EAPI=5
 inherit eutils cdrom games
 
 DESCRIPTION="iD Software's Quake 1 ... the data files"
@@ -41,27 +41,25 @@ src_unpack() {
                echo ">>> Unpacking q101_int.lha to ${PWD}"
                cat "${CDROM_ROOT}"/q101_int.1 "${CDROM_ROOT}"/q101_int.2 > \
                        "${S}"/q101_int.exe
-               lha xqf "${S}"/q101_int.exe || die "failure unpacking q101_int.exe"
+               lha xqf "${S}"/q101_int.exe || die
                rm -f q101_int.exe
        elif [[ ${CDROM_SET} == "3" ]] ; then
                echo ">>> Unpacking resource.1 to ${PWD}"
-               lha xqf "${CDROM_ROOT}"/resource.1 || die "failure unpacking resource.1"
+               lha xqf "${CDROM_ROOT}"/resource.1 || die
        fi
 }
 
 src_install() {
        insinto "${GAMES_DATADIR}"/quake1/id1
        case ${CDROM_SET} in
-               0)  doins "${CDROM_ROOT}"/id1/* || die "doins pak files"
+               0)  doins "${CDROM_ROOT}"/id1/*
                    dodoc "${CDROM_ROOT}"/*.txt
                    ;;
-               1|3)doins id1/* || die "doins pak files"
+               1|3)doins id1/*
                    dodoc *.txt
                    ;;
-               2)  newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak \
-                               || die "ins pak0.pak failed"
-                   newins "${CDROM_ROOT}"/Setup/ID1/PAK1.PAK pak1.pak \
-                               || die "ins pak1.pak failed"
+               2)  newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak
+                   newins "${CDROM_ROOT}"/Setup/ID1/PAK1.PAK pak1.pak
                    dodoc "${CDROM_ROOT}"/Docs/*
                    ;;
        esac