app-text/libwpd: Fix build with GCC-4.8
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 13 Jan 2019 17:41:00 +0000 (18:41 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 13 Jan 2019 20:45:02 +0000 (21:45 +0100)
Closes: https://bugs.gentoo.org/674402
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch [new file with mode: 0644]
app-text/libwpd/libwpd-0.10.3.ebuild

diff --git a/app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch b/app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch
new file mode 100644 (file)
index 0000000..f47847c
--- /dev/null
@@ -0,0 +1,16 @@
+Authored by:  David Tardon David Tardon 2018-12-30
+Commit 333c8a26f231bea26ec3d56245315041bbf5577f
+
+fix build with gcc 4.8
+
+--- a/src/lib/WPXTable.h
++++ b/src/lib/WPXTable.h
+@@ -53,7 +53,7 @@
+       ~WPXTable();
+       void insertRow();
+       void insertCell(unsigned char colSpan, unsigned char rowSpan, unsigned char borderBits);
+-      const WPXTableCell  *getCell(size_t i, size_t j)
++      const WPXTableCell  *getCell(std::size_t i, std::size_t j)
+       {
+               return &(m_tableRows[i])[j];
+       }
index febfff6725bf867d8c2a28dd5052b24043d8e0ed..469e0bc7eba3a7c126dc28109b95729e4f508d70 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -21,6 +21,8 @@ BDEPEND="
        doc? ( app-doc/doxygen )
 "
 
+PATCHES=( "${FILESDIR}/${P}-gcc-4.8.patch" )
+
 src_configure() {
        local myeconfargs=(
                --program-suffix=-${SLOT}