sys-devel/sparse: drop 'install-all' reference, bug #671356
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 26 Jan 2019 22:07:34 +0000 (22:07 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 26 Jan 2019 22:07:54 +0000 (22:07 +0000)
Daniel reports that install-all disappeared in
https://git.kernel.org/pub/scm/devel/sparse/sparse.git/commit/Makefile?id=3b7d5e200ac64de2914b930933491b548b3d0bc0
and now breaks the build.

Use default 'make all' unconditionally.

Reported-by: Daniel M. Weeks
Closes: https://bugs.gentoo.org/671356
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/sparse/sparse-9999.ebuild

index 43d03a624df27681a7738ec3c20615fe65c45c1c..8850a866452c3258f145857293710705c9e2f6fe 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -39,7 +39,3 @@ src_prepare() {
        export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
        default
 }
-
-src_compile() {
-       emake $(usex test all all-installable)
-}