net-analyzer/tcpdump: Prevent more -L/usr/lib injections
authorJeroen Roovers <jer@gentoo.org>
Thu, 9 Jan 2020 13:38:41 +0000 (14:38 +0100)
committerJeroen Roovers <jer@gentoo.org>
Thu, 9 Jan 2020 13:39:04 +0000 (14:39 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/tcpdump/files/tcpdump-9999-libdir.patch [new file with mode: 0644]
net-analyzer/tcpdump/tcpdump-9999.ebuild

diff --git a/net-analyzer/tcpdump/files/tcpdump-9999-libdir.patch b/net-analyzer/tcpdump/files/tcpdump-9999-libdir.patch
new file mode 100644 (file)
index 0000000..852ea6b
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -371,7 +371,7 @@
+ if test "$ipv6" = "yes" -a "$ipv6lib" != "none"; then
+       if test -d $ipv6libdir -a -f $ipv6libdir/lib$ipv6lib.a; then
+-              LIBS="-L$ipv6libdir -l$ipv6lib $LIBS"
++              LIBS="-l$ipv6lib $LIBS"
+               echo "You have $ipv6lib library, using it"
+       else
+               if test "$ipv6trylibc" = "yes"; then
+@@ -891,7 +891,6 @@
+               # at the front of the header and library search path.
+               #
+               CFLAGS="-I$withval/include $CFLAGS"
+-              LIBS="-L$withval/lib $LIBS"
+       fi
+ ],[
+       #
index 52faf660b30f0a0356ed9ff9b77392608f2b6c91..a4285888f60c8358c8d55c2f87a3dce4b00396c2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -36,10 +36,14 @@ DEPEND="
        ${RDEPEND}
        drop-root? ( virtual/pkgconfig )
        test? (
-               || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+               >=net-libs/libpcap-1.9.1
                dev-lang/perl
+               || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
        )
 "
+PATCHES=(
+       "${FILESDIR}"/${PN}-9999-libdir.patch
+)
 
 pkg_setup() {
        if use drop-root || use suid; then