dev-python/pyquery: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 15:58:36 +0000 (17:58 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 18:31:52 +0000 (20:31 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyquery/pyquery-1.4.1-r1.ebuild

index 655f9317f0a537f8c614c04aca0c7c2e8c156b9d..86bf2c88a3db4c74c887f2ea258db9071da00459 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1 eutils
 
@@ -21,7 +21,6 @@ RDEPEND="
        >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
        >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND}
                dev-python/beautifulsoup[${PYTHON_USEDEP}]
                dev-python/requests[${PYTHON_USEDEP}]