x11-misc/qt5ct: correctly apply KDE styles
authorIlya Tumaykin <itumaykin@gmail.com>
Fri, 27 Jan 2017 19:31:53 +0000 (22:31 +0300)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 29 Jan 2017 16:52:00 +0000 (03:52 +1100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch [new file with mode: 0644]
x11-misc/qt5ct/qt5ct-0.29-r1.ebuild [moved from x11-misc/qt5ct/qt5ct-0.29.ebuild with 95% similarity]

diff --git a/x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch b/x11-misc/qt5ct/files/qt5ct-0.29-fix-kde-styles.patch
new file mode 100644 (file)
index 0000000..d15609d
--- /dev/null
@@ -0,0 +1,20 @@
+Correctly apply selected theme to KDE apps.
+
+https://sourceforge.net/p/qt5ct/tickets/32/
+
+Index: src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
+===================================================================
+--- a/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp        (revision 368)
++++ b/src/qt5ct-qtplugin/qt5ctplatformtheme.cpp        (revision 369)
+@@ -101,9 +101,8 @@
+
+ const QPalette *Qt5CTPlatformTheme::palette(QPlatformTheme::Palette type) const
+ {
+-    if(m_customPalette && m_usePalette)
+-        return m_customPalette;
+-    return QPlatformTheme::palette(type);
++    Q_UNUSED(type);
++    return (m_usePalette ? m_customPalette : 0);
+ }
+
+ const QFont *Qt5CTPlatformTheme::font(QPlatformTheme::Font type) const
similarity index 95%
rename from x11-misc/qt5ct/qt5ct-0.29.ebuild
rename to x11-misc/qt5ct/qt5ct-0.29-r1.ebuild
index c449014e46397f98cba6c8d0771744bb940de790..2563ebe254f2322b6179b0e3695cb9760f645477 100644 (file)
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
        dev-qt/linguist-tools:5
 "
 
+PATCHES=( "${FILESDIR}/${P}-fix-kde-styles.patch" )
+
 src_configure() {
        eqmake5 DEFINES="$(usex systray '' QT_NO_SYSTEMTRAYICON)" ${PN}.pro
 }