media-gfx/jpeg2ps: Update ebuild for EAPI 7.
authorUlrich Müller <ulm@gentoo.org>
Wed, 6 Nov 2019 22:54:54 +0000 (23:54 +0100)
committerUlrich Müller <ulm@gentoo.org>
Wed, 6 Nov 2019 23:00:34 +0000 (00:00 +0100)
Closes: https://bugs.gentoo.org/335526
Closes: https://bugs.gentoo.org/468664
Bug: https://bugs.gentoo.org/697288
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
media-gfx/jpeg2ps/files/jpeg2ps-1.9-include.diff
media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild [new file with mode: 0644]

index f07b69c5bc6a0f489df69920a110477a751ffcba..ffc332333651cc32f9784d9cfab67a72e86c4978 100644 (file)
@@ -1,6 +1,7 @@
-diff --exclude='*~' -Naur jpeg2ps-1.9.orig/asc85ec.c jpeg2ps-1.9/asc85ec.c
---- jpeg2ps-1.9.orig/asc85ec.c 2005-09-10 23:02:15.000000000 -0300
-+++ jpeg2ps-1.9/asc85ec.c      2005-09-10 23:08:08.000000000 -0300
+https://bugs.gentoo.org/105561
+
+--- jpeg2ps-1.9.orig/asc85ec.c
++++ jpeg2ps-1.9/asc85ec.c
 @@ -3,6 +3,7 @@
  
  #include <stdio.h>
diff --git a/media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild b/media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild
new file mode 100644 (file)
index 0000000..7d2bc41
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="Convert JPEG images to Postscript using a wrapper"
+HOMEPAGE="https://web.archive.org/web/20131003144811/http://www.pdflib.com/download/free-software/jpeg2ps/"
+SRC_URI="https://web.archive.org/web/20131003165952/http://www.pdflib.com/fileadmin/pdflib/products/more/${PN}/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="metric"
+
+PATCHES=("${FILESDIR}"/${P}-include.diff)
+
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               LD="$(tc-getCC)" \
+               CFLAGS="-c ${CFLAGS} $(usex metric "-DA4" "")" \
+               LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       dobin jpeg2ps
+       doman jpeg2ps.1
+       dodoc jpeg2ps.txt
+
+       if use metric; then
+               DOC_CONTENTS="By default, this installation of jpeg2ps will generate
+                       A4 size output.  You can force letter output with
+                       \n\tjpeg2ps -p letter file.jpg > file.ps"
+       else
+               DOC_CONTENTS="By default, this installation of jpeg2ps will generate
+                       letter size output.  You can force A4 output with
+                       \n\tjpeg2ps -p a4 file.jpg > file.ps"
+       fi
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}