net-firewall/firehol: Bump to 3.1.4
authorAlessandro Rosetti <alessandro.rosetti@gmail.com>
Thu, 7 Sep 2017 00:34:55 +0000 (02:34 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Fri, 8 Sep 2017 19:38:53 +0000 (22:38 +0300)
net-firewall/firehol/Manifest
net-firewall/firehol/firehol-3.1.4.ebuild [new file with mode: 0644]

index 8d9659209610971eea560633eb167cc5b258079a..05b7e77efd3b333da3cf72d1736558a73c68bd5e 100644 (file)
@@ -1 +1,2 @@
 DIST firehol-3.1.3.tar.xz 1476220 SHA256 4693d7238d411ffcaacd1febf7231a9e69657e8b198f1b0726429bdb258372e7 SHA512 6c75b57650d918cfc485f6eb01d69694acd5c7b487a10a566fc26b8d5e0cd6a6a9a09bd8d3219bf4e78aa4fe47f83e5ac399107a07770b787e1ccba3078c5f3f WHIRLPOOL b14628fe4e9f7d0b45231a0720b4142dfd41edadd5bafd74650c8af2c67b5a535b8c32e03c696a06332455b18b18900c063a7cdbeb7582c15b409a83cfea83b7
+DIST firehol-3.1.4.tar.xz 1481320 SHA256 a73c26bb81dfa4c476b7b02c3e71c34715c044c496feea56551614a195b93d7e SHA512 1a17b6e810274b346f66788c4c4736421583e6a4ed76df7a1d7f46dcb99e434460998c05755c8342941413d23c02e2ca0d0bf2123cb555a6c7513d24983a13ed WHIRLPOOL b551cd98641a3ae74a06d29080c70451ee7bd2174f0658ed91c55d42691c4f07d7c248ed63d208c6ef7084294726482ab1d398a79fddeec88865b7308ee10cff
diff --git a/net-firewall/firehol/firehol-3.1.4.ebuild b/net-firewall/firehol/firehol-3.1.4.ebuild
new file mode 100644 (file)
index 0000000..f95d2d0
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="https://firehol.org/ https://github.com/firehol/firehol"
+SRC_URI="https://github.com/firehol/firehol/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc ipv6 ipset"
+KEYWORDS="~amd64 ~arm ~ppc"
+
+RDEPEND="net-firewall/iptables
+       sys-apps/iproute2[-minimal,ipv6?]
+       net-misc/iputils[ipv6?]
+       net-misc/iprange
+       net-analyzer/traceroute
+       virtual/modutils
+       app-arch/gzip
+       ipset? (
+               net-firewall/ipset
+       )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+       local KCONFIG_OPTS=" \
+               ~IP_NF_FILTER \
+               ~IP_NF_IPTABLES \
+               ~IP_NF_MANGLE \
+               ~IP_NF_TARGET_MASQUERADE
+               ~IP_NF_TARGET_REDIRECT \
+               ~IP_NF_TARGET_REJECT \
+               ~NETFILTER_XT_MATCH_LIMIT \
+               ~NETFILTER_XT_MATCH_OWNER \
+               ~NETFILTER_XT_MATCH_STATE \
+               ~NF_CONNTRACK \
+               ~NF_CONNTRACK_IPV4 \
+               ~NF_CONNTRACK_MARK \
+               ~NF_NAT \
+               ~NF_NAT_FTP \
+               ~NF_NAT_IRC \
+       "
+       linux-info_pkg_setup
+}
+
+src_configure() {
+       econf \
+               --disable-vnetbuild \
+               $(use_enable ipset update-ipsets) \
+               $(use_enable doc) \
+               $(use_enable ipv6)
+}
+
+src_install() {
+       default
+
+       newconfd "${FILESDIR}"/firehol.conf.d firehol
+       newinitd "${FILESDIR}"/firehol.initrd firehol
+       newconfd "${FILESDIR}"/fireqos.conf.d fireqos
+       newinitd "${FILESDIR}"/fireqos.initrd fireqos
+}