dev-python/urllib3: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:06:13 +0000 (22:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:09:43 +0000 (22:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/urllib3/urllib3-1.24.2.ebuild
dev-python/urllib3/urllib3-1.25.7.ebuild
dev-python/urllib3/urllib3-1.25.8.ebuild

index 5c781b4effa647953103b5bb63ce23eabf761522..744dfd74e26d8c91f347684d2c2fe49434995d38 100644 (file)
@@ -25,7 +25,9 @@ RDEPEND="
        >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
        >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
        >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
-       virtual/python-ipaddress[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/ipaddress[${PYTHON_USEDEP}]
+       ' -2)
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
index 7d7b50ac8af2e01069f403e6bd2c57faf0d96d42..de5188583cf731b9f0b9441735eb17282f5c79f1 100644 (file)
@@ -25,7 +25,9 @@ RDEPEND="
        >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
        >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
        >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
-       virtual/python-ipaddress[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/ipaddress[${PYTHON_USEDEP}]
+       ' -2)
        brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
 "
 BDEPEND="
index 296a106fd7aa767e7f56f1b9aa80a679b619a114..4770e497d12f0b0030b8f7a029b13dd80a9dfdc3 100644 (file)
@@ -25,7 +25,9 @@ RDEPEND="
        >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
        >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
        >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
-       virtual/python-ipaddress[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/ipaddress[${PYTHON_USEDEP}]
+       ' -2)
        brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
 "
 BDEPEND="