Remove obsolete version. Version bump.
authorAlin Năstac <mrness@gentoo.org>
Fri, 8 Dec 2006 21:12:34 +0000 (21:12 +0000)
committerAlin Năstac <mrness@gentoo.org>
Fri, 8 Dec 2006 21:12:34 +0000 (21:12 +0000)
Package-Manager: portage-2.1.1-r1

net-dialup/xl2tpd/ChangeLog
net-dialup/xl2tpd/files/digest-xl2tpd-1.1.06 [new file with mode: 0644]
net-dialup/xl2tpd/files/xl2tpd-init [new file with mode: 0644]
net-dialup/xl2tpd/xl2tpd-1.1.06.ebuild [new file with mode: 0644]

index 92406ed17e0a0819a5aa999faa1b4f13598d56ce..6eee0eca0945818c64fdd9242155b92f8a08da0d 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-dialup/xl2tpd
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.2 2006/11/06 09:12:32 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.3 2006/12/08 21:12:34 mrness Exp $
+
+*xl2tpd-1.1.06 (08 Dec 2006)
+
+  08 Dec 2006; Alin Năstac <mrness@gentoo.org> +files/xl2tpd-init,
+  +xl2tpd-1.1.06.ebuild, -xl2tpd-1.04.ebuild:
+  Remove obsolete version. Version bump.
 
 *xl2tpd-1.1.05 (06 Nov 2006)
 
diff --git a/net-dialup/xl2tpd/files/digest-xl2tpd-1.1.06 b/net-dialup/xl2tpd/files/digest-xl2tpd-1.1.06
new file mode 100644 (file)
index 0000000..95b00dd
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 44e5a85ecce622a0f55aafc42ce589a8 xl2tpd-1.1.06.tar.gz 149891
+RMD160 d6f03631cc2dee16110a311c6defd3b844face03 xl2tpd-1.1.06.tar.gz 149891
+SHA256 98aeec5b5cc9dbf292482dffeefe01072905739062a78215a970ce09bb465e63 xl2tpd-1.1.06.tar.gz 149891
diff --git a/net-dialup/xl2tpd/files/xl2tpd-init b/net-dialup/xl2tpd/files/xl2tpd-init
new file mode 100644 (file)
index 0000000..1f32d26
--- /dev/null
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/files/xl2tpd-init,v 1.1 2006/12/08 21:12:34 mrness Exp $
+
+depend() {
+       need net
+}
+
+checkconfig() {
+       if [[ ! -f /etc/xl2tpd/xl2tpd.conf ]] ; then
+               eerror "Missing /etc/xl2tpd/xl2tpd.conf configuration file!"
+               eerror "Example configuration file could be found in doc directory."
+               return 1
+       fi
+
+       return 0
+}
+
+start() {
+       checkconfig || return 1
+
+       ebegin "Starting xl2tpd"
+       start-stop-daemon --start --quiet --exec /usr/sbin/xl2tpd
+       eend $?
+}
+
+stop() {
+       ebegin "Stopping xl2tpd"
+       start-stop-daemon --stop --quiet --pidfile /var/run/xl2tpd/xl2tpd.pid
+       eend $?
+}
diff --git a/net-dialup/xl2tpd/xl2tpd-1.1.06.ebuild b/net-dialup/xl2tpd/xl2tpd-1.1.06.ebuild
new file mode 100644 (file)
index 0000000..8ffe73a
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.1.06.ebuild,v 1.1 2006/12/08 21:12:34 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-dialup/l2tpd
+       net-dialup/ppp"
+
+src_install() {
+       dosbin xl2tpd || die 'xl2tpd binary not found'
+       doman doc/*.[85]
+
+       dodoc CREDITS README \
+               doc/rfc2661.txt doc/*.sample
+
+       dodir /etc/xl2tpd
+       head -n 2 doc/l2tp-secrets.sample > "${D}/etc/xl2tpd/l2tp-secrets"
+       fperms 0600 /etc/xl2tpd/l2tp-secrets
+       newinitd "${FILESDIR}/xl2tpd-init" xl2tpd
+
+       keepdir /var/run/xl2tpd
+}
+
+#TODO: remove preinst and postinst functions some time around July 2007
+pkg_preinst() {
+       if has_version "<=${CATEGORY}/${PN}-1.1.05" && [[ -d "${ROOT}/etc/l2tpd" ]]; then
+               ebegin "Migrating /etc/l2tpd to /etc/xl2tpd"
+               if [[ -f "${ROOT}/etc/l2tpd/l2tpd.conf" ]] ; then
+                       sed -i -e 's:/etc/l2tpd/:/etc/xl2tpd/:g' "${ROOT}/etc/l2tpd/l2tpd.conf"
+                       mv "${ROOT}/etc/l2tpd/l2tpd.conf" "${ROOT}/etc/l2tpd/xl2tpd.conf"
+               fi
+               mv -f "${ROOT}/etc/l2tpd" "${ROOT}/etc/xl2tpd"
+               eend
+       fi
+}
+
+pkg_postinst() {
+       if has_version "<=${CATEGORY}/${PN}-1.1.05"; then
+               ewarn "The daemon and service have been renamed from l2tpd to xl2tpd."
+               ewarn "Please remove the old init script and configure your system to use"
+               ewarn "the new init script:"
+               ewarn "   ${HILITE}/etc/init.d/l2tpd stop${NORMAL}"
+               ewarn "   ${HILITE}rc-update del l2tpd${NORMAL}"
+               ewarn "   ${HILITE}rm /etc/init.d/l2tpd${NORMAL}"
+               ewarn "   ${HILITE}rc-update add xl2tpd${NORMAL}"
+               ewarn "   ${HILITE}/etc/init.d/xl2tpd start${NORMAL}"
+               ebeep
+       fi
+}