0.11.3 version bump, remove old ebuilds.
authorMarcelo Góes <vanquirius@gentoo.org>
Wed, 31 Jan 2007 22:44:16 +0000 (22:44 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Wed, 31 Jan 2007 22:44:16 +0000 (22:44 +0000)
Package-Manager: portage-2.1.1-r2

net-analyzer/pmacct/ChangeLog
net-analyzer/pmacct/files/digest-pmacct-0.11.3 [new file with mode: 0644]
net-analyzer/pmacct/pmacct-0.11.3.ebuild [new file with mode: 0644]

index 6643328f8cad659630c1372130e1998f10a5ff3f..75e2e39aff5f3530f00bcc9fdd6e81669d293a33 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/pmacct
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.45 2007/01/15 22:00:38 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.46 2007/01/31 22:44:16 vanquirius Exp $
+
+*pmacct-0.11.3 (31 Jan 2007)
+
+  31 Jan 2007; Marcelo Goes <vanquirius@gentoo.org> -pmacct-0.10.3.ebuild,
+  -pmacct-0.11.2.ebuild, +pmacct-0.11.3.ebuild:
+  0.11.3 version bump, remove old ebuilds.
 
 *pmacct-0.11.2-r1 (15 Jan 2007)
 
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.11.3 b/net-analyzer/pmacct/files/digest-pmacct-0.11.3
new file mode 100644 (file)
index 0000000..bc91e55
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 49052b47201afa1c3ed29e910f661ea1 pmacct-0.11.3.tar.gz 417160
+RMD160 b8192ece79b0a1697237700843972bd44f728be0 pmacct-0.11.3.tar.gz 417160
+SHA256 ff591cb5e1b17ab6f148d10534164307c8f6309b46067bc9be8a32f086a8388d pmacct-0.11.3.tar.gz 417160
diff --git a/net-analyzer/pmacct/pmacct-0.11.3.ebuild b/net-analyzer/pmacct/pmacct-0.11.3.ebuild
new file mode 100644 (file)
index 0000000..8ec7d7c
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.3.ebuild,v 1.1 2007/01/31 22:44:16 vanquirius Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres sqlite3"
+
+RDEPEND="net-libs/libpcap
+       mysql? ( virtual/mysql )
+       postgres? ( dev-db/postgresql )
+       sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+       econf \
+               $(use_enable mysql) \
+               $(use_enable postgres pgsql) \
+               $(use_enable mmap) \
+               $(use_enable ipv6) \
+               $(use_enable debug) \
+               $(use_enable 64bit) \
+               $(use_enable sqlite3) \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+       dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+               docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+       for dirname in examples sql; do
+               docinto ${dirname}
+               dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+       done
+
+       newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+       newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+       insinto /etc
+       newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+               die "newins failed"
+}