app-antivirus/clamav: remove --disable-gcc-vcheck from configure flags.
authorMichael Orlitzky <mjo@gentoo.org>
Wed, 16 Oct 2019 11:24:26 +0000 (07:24 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Wed, 16 Oct 2019 11:31:31 +0000 (07:31 -0400)
Our ClamAV builds have passed the --disable-gcc-vcheck flag to its
configure script for a while. This is intended to skip a (pointless,
on Gentoo) test for old broken versions of GCC, but accidentally leads
to "-O0" being inserted into the CFLAGS. That in turn causes noticeable
performance degradation.

Since the GCC version check is harmless aside from some wasted time,
it seems the simplest solution here is to drop "--disable-gcc-vcheck"
from the build. This commit adds a new revision of the latest unstable
version that does just that.

Closes: https://bugs.gentoo.org/670828
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
app-antivirus/clamav/clamav-0.102.0-r1.ebuild [moved from app-antivirus/clamav/clamav-0.102.0.ebuild with 95% similarity]

similarity index 95%
rename from app-antivirus/clamav/clamav-0.102.0.ebuild
rename to app-antivirus/clamav/clamav-0.102.0-r1.ebuild
index 85d704dacfe6f94bb528839bd9139f8fd28fdea2..1d65b447b4da015c7d2bfdd273cead47117f0266 100644 (file)
@@ -74,12 +74,12 @@ src_configure() {
        JSONUSE=""
 
        if [ use clamsubmit ] || [ use metadata-analysis-api ]; then
-           # either of those 2 requires libjson.
-           # clamsubmit will be built as soon as libjson and curl are found
-           # but we only install the binary if requested
-           JSONUSE="--with-libjson=/usr"
+               # either of those 2 requires libjson.
+               # clamsubmit will be built as soon as libjson and curl are found
+               # but we only install the binary if requested
+               JSONUSE="--with-libjson=/usr"
        else
-           JSONUSE="--without-libjson"
+               JSONUSE="--without-libjson"
        fi
 
        econf \
@@ -98,7 +98,6 @@ src_configure() {
                --with-system-libmspack \
                --cache-file="${S}"/config.cache \
                --disable-experimental \
-               --disable-gcc-vcheck \
                --disable-zlib-vcheck \
                --enable-id-check \
                --with-dbdir="${EPREFIX}"/var/lib/clamav \